Lenovo Yoga 720 Fingerprint Scanner, Touchscreen Unresponsive

fusion20

Beta member
Messages
1
Location
Canada
Hello all,

I will try and make this short and to the point and keep my frustration with Lenovo at bay...

Some history of the issue:
In early August I bought a new Yoga 720-12IKB Laptop (ideapad) directly from the Lenovo website. Previously I have had quite good experience with their ideapads so I thought I would buy another one as I thought they were a rather trusted company with laptops. Through reading multiple reviews on the 720 and others in the YOGA family, I landed on the 720 and decided to purchase it. For the first few months it worked great, I bought the active pen 2 but didn't use it as much as I thought I would; but nonetheless it worked fine and the touchscreen did as well. As I am writing this post on March 28, 2019, the touchscreen has been unresponsive for approximately 3-4 months now and the fingerprint scanner suddenly stopped working in the past few days.

I will now go over what I have done to try and fix these issues:

For the fingerprint scanner I have read this article:
https://windowsreport.com/fix-fingerprint-reader-not-working-sleep-windows-10/
and followed a few of their steps which I thought would work, none prevailed. The most peculiar of the issue though is that it happened suddenly and without any change in my laptop.

After checking device manager there is no sign of Biometric devices at all and no sign of the Synactics Fingerprint Driver anywhere for that matter...

Also, when I try and install the driver directly from the website I get a message stating that the driver is already installed, but as I mentioned earlier, it is nowhere to be seen in the device manager.

Also (this may be obvious) but Windows tells me there is no fingerprint device installed on my laptop (which is probably because there isn't a driver).

To move on to the touchscreen issue, it is a little more extensive to what I have tried...

IMPORTANT: I should mention that the touchscreen became nonfunctional AFTER a BIOS update.


I have tried to update, disable/re-enable, and uninstall/re-install the driver (HID-compliant touch screen) multiple times and it does not work.

I have tried to contact LENOVO support and this is what they told me:


ASSISTANT: We will try some troubleshooting steps to diagnose the issue. If we found out that there is a hardware failure on the unit, we might end up processing a repair service request.
ME: ok
ASSISTANT: Access BIOS:

• Hold the Power button down for at least 15 sec. to shut down the machine (make sure that there is no lights)
• Unplug the AC adapter
• Reconnect the AC adapter
• On the left or right side of the laptop I want you to look for a small hole with an inverted arrow.
• Press the hole with a pin or a paperclip
• Unit will automatically turn on, please select BIOS set up.

• From there, please press FN + F9 or F9 alone on the keyboard to load back to default settings then Fn + F10 or F10 alone to save and exit.
• Unit will automatically reboot
• Test the unit
ASSISTANT: Reinstall the Touchscreen Driver

1.Go to the Device Manager
2.In the Device Manager, click View from the menu and click Show hidden devices option.
3.Look for Human Interface Devices in the list and expand it. Right-click and Uninstall everything that starts with HID and USB.
Restart the computer after uninstalling and check for touch functionality.

None of this worked, obviously.

Then, because my manufacturer warranty is still in tact, I tried to see if a refund was manageable if I seemed angry enough (a long shot I know but I was fed up)... After some discussion with the assistant, I told her that it was after a BIOS update so it has to be a software issue so shipping it back to them to be repaired would be unnecessary.

The assistant told me to do a recovery:

ONE KEY RECOVER

If there's no hardware error then it means that the issue is the Operating system of the computer, if it is just the Operating system then the best way that we can actually do to fix this issue is by Performing the Onekey recovery to your computer
However just to set a proper expectation, Onekey Recovery will set back everything back to default which means if you have any important files on the computer then it will be deleted. Thus, I highly recommend that you back up all data to an external repository like hard drive or memory stick. Any programs you added or system updates installed in the computer will have to be reinstalled or re-applied. ?

1. Look for the pinhole button with inverted U icon next to either the dc in port or power button.
2. Please shut down the laptop completely then turn it on using that tiny hole.
3. In the Novo menu that will show up, choose System Recovery.
4. Next is to choose Restore form initial backup.
5. Just confirm it on the succeeding screens and once it initializes, just wait for it to complete the process.
6. This can take 15-45 minutes depending on the machine.

I have not yet tried to do the recovery because I have not had time to do a full backup as I am in school and require my laptop daily. I was planning on doing in a month or so when school is finished if I cannot find a solution prior.

Apologies for the long post, I am really on my last legs here with these issues. It annoyed me enough that suddenly the touchscreen stopped working and there seems to be no fix to it and then to top that off my fingerprint reader suddenly stopped as well.

I am looking for any suggestions you may have. Help me, Techist, you are my only hope.
 
Top