Is my floppy drive broken?

Not open for further replies.


Solid State Member
I recently stripped down an old PC to upgrade to a newer system. When I boot up the new build, the floppy reading LED comes on immeadiately and stays on permanently. Whilst in Windows 98SE I have removed the floppy drivers and rebooted. The New hardware wizard locates the floppy and reinstalls the drivers - still no joy. In DOS the drive is also invalid. In the BIOS I can't seem to find specific function for searching for a 1.5" drive I have to manually set it to this.
Has anyone got any ideas?
Do I need to reset the CMOS or upgrade BIOS?
Or do I just need a new floppy drive?
Thanx for your help

You must have your floppy cable on backward. Check for red on pin1. Usually I had this problem when booting a machine when I had the floppy cable on w/ red stripe on the wrong end. Of course I would think "I'm confident I got everything, I'll go ahead a screw in all the screws..." only to have the red light stay on...
Thanks Chalk,
Yeah thats fixed it. Its funny how the tab on the cable slots into the gap on the FDD for 'fool-prove' installation, yet means it's connected the wrong way round!
Not open for further replies.
Top Bottom