Corrupted thumb drive (invalid device descriptor)


In Runtime
My thumb drive got corrupted while seatools was loading (it was an older version). I backed it up, but not for a couple of weeks. Windows pops up and says it doesn't recognize it when I put it in, and it shows up in Device Manager as-

unknown usb device (invalid device descriptor)

No file recovery program worked - the drive just wouldn't show. I tried all the steps here. (adjusting the power options, reinstalling the drivers and I even reinstalled Windows).

Before I take it to a data recovery pro (any estimate on the cost for this?) I'm aware of some recovery programs that can run in either DOS or in boot time- I tried the Seatools one (Seaboot) but couldn't get anywhere ("No Caching mode page found")
It might be toast. I don't see why Seatools would corrupt it. I use Seatools and I have never had it corrupt any of my drives. I use Seagate File Recovery for Windows software when I have tried to recover lost files with moderate success. That is the paid for version though. Be aware that if you go to a file recovery agency they may not be able to recover anything but they will still charge you and they aint cheap.
Top Bottom