Hard drive fails File Structure test

Status
Not open for further replies.

tropicalfish

Beta member
Messages
4
Hello, I am new here.
I finally decided I would quit figuring out which forum belongs in, and decided this one was most relevant.
One of my two Seagate harddrives fails the file structure test. I did a reformat this past weekend, and then I ran a hard drive test after the Windows installation. The drive passed-- the PARTITION failed the file structure test.
I am running two Seagate ST3120026A drives. One is much newer. The newer one is the one that is showing up with issues, and has the OS on it. I don't know if the drive previously showed this problem, but the second older drive passes the tests.

I did a bunch of Windows check disk all over it, making sure I checked the "attempt to reallocate blah blah". This, apparently, did nothing. I then reformmatted and reinstalled Windows. Same result. File structure test fails.
Finally, I did a full zero fill on the drive, starting at about 14:00 CDT yesterday, I stopped it at 22:44 CDT at 94%. I assumed this did enough, and I formatted a new NTFS partition onto the drive with the Seagate utility. I did a scan--tests passed.
I proceeded to install Windows XP. This is Windows XP SP1 upgrade disk. It said I needed a previous version of Windows disk, and I dug through my CD collection quickly, and found Windows 95, covered in dust. The CD was in good condition, so I stuck it into the drive. Then it asked for the Windows XP disk. I made sure I selected the option to not do any changes to the file system on the drive.. At this time the drive is NTFS. I install Windows, then it takes forever to shut down. It shows the Shut down window with the color bar still moving and the computer still responsive. After about 30 minutes I hold the power button down to shut it off.
I restart to do the tests again. The drive passes the test, but the partition does not. I loaded into Windows, and the disk scanning didn't show up during Windows boot despite the fact I turned it off manually on the power switch. It seems everything is normal. I do the drive scans and "attempt to reallocate blah" and then do the Seagate drive tests again. The drive passes but the partition fails.

My system specifications are:

AMD Duron 1600
SOYO Sy-KT600 Dragon Plus V2.0
Two ST3120026A (Yes, I think Seagate rocks, ever since our very first 100 mb something Seagate hard drive (I don't use that drive anymore obviously. I opened it up, then threw it away.))
Optical drives... (I don't think exact specs are needed)
A floppy drive
PNY nVidia GeForce FX5500 128 mb AGP

Everything stayed the same as always... except I decided to add a few intake fans directed at the hard drives, I don't think this affects anything.
 

networkgeek

In Runtime
Messages
367
Location
TN
dont know if you have solved this yet. but if not. download Drive fitness test (google it) and use the iso to make a bootable cd. boot off that cd and test the drive.
 

an51r

In Runtime
Messages
438
Do not worry about it, all seagates have a five year warranty, go to the seagate website and put in your serial number thats all you need. Then rma the drive and maybe you will get lucky like I did and receive a bigger drive.
 
Status
Not open for further replies.
Top Bottom