Help: Invalid System Disk

Not open for further replies.


Baseband Member
Ok so here is the situation..

I had an Emachine , but gave the emachine mobo to a friend , and I then took out a Soyo 7SBB mobo that I had and put in into the PC.I had a 20GIG Maxtor in the emachine that I took out and also put into the new case.
The HD has WinXP Pro.The motherboard comes on , detects the HD , CD Drive , FDD , Memory , etc;.
However the mobo does not boot into XP.Instead if gives me an error : Invalid System Disk . I changed the IDE cable , set the jumpers to Cable Select / Master , Soyo help said I should reset the CMOS , which I did and I still get the same message.
I got the mobo in 99'.Never used it until now.I figured that it needed the newest BIOS upgrade , which I got , but when I boot to the 98se bootdisk , I get Stack Errors ( Stack config.sys , happens everytime with 10 different bootdisks).
My guess which I havn't been able to test due to the Stack errors , is that the BIOS is too old to even detect XP PRO.Soyo says XP is supported , but XP is just a revamped NT/2k which should be supported no matter what ( old or new bios ).
Damn :( Hopefully someone will give me the answer :)
Well before I did anything , I upgrade the BIOS with the latest update from SOYO and all went well.I then installed XP over the old and everything went ok.I got to the end where XP restarts the PC , I let it restart.Then the mobo detected all the parts well , where then I got to the DMI .. succesful screen.
XP is supposed to take over to finish the installation but I got a "Could not boot from CD" , so I restarted , then I got "Could not load Operating System" , then I said "@#*!" .
The last thing I want to do is reformat and a clean install.Any more suggestions? If I do have to do a clean install , then so be it , I just want to make sure I tried everything :)
:( Im tired of trying to fix this P.o.S :) Guess i'll need to whip out a new HD and copy all my info over to that one. It isn't 7200 rpm like the Original but I can transfer back once all data is there :)

Thanks for the suggestions every1 .
Well I did what I didn't want to do , but problems arose :)

After the initial setup of XP Pro ( format , then CD installs files , "computer will now reboot and continue installation" etc;) , the PC restarts and I prepare to enter information such as CD Key and time zone and whatnot.But the HD never boots into the second part of the setup.Instead the XP CD starts up again and loads up the files again , and gives me the option to repair or re-install , I went with repair a couple of times , it reboots and same deal.I went with a clean install again (format) and the same thing.If I leave the CD Alone where it says "Press any key to boot from disk" I get..

Press Any Key to Boot From CD ...... Failed to load Operating System

Im pretty sure its the mobo by now because I tried with another mobo ( an old 333mhz emachine mobo and an 600mhz emachine mobo ) and everything installed fine.

This mobo is a Soyo 7S-BB AT Mobo , I have upgraded to the latest BIOS but no go.I called Soyo , but no one answers.Time to email again :)

Hopefully someone has the solution :) (Other than , format and do a clean install :D )
Not open for further replies.
Top Bottom