Case LED Screen Probs

wee2john

Baseband Member
Messages
50
Ok so I have an eagle forte viper case with an lcd screen built in to the front of it. The power cable has 3 fan connections, one cpu sensor and the lcd screen power cable. Everything works but the screen does not do anything. Whats wrong with it??
 

Russel1

Daemon Poster
Messages
1,037
Ok so I have an eagle forte viper case with an lcd screen built in to the front of it. The power cable has 3 fan connections, one cpu sensor and the lcd screen power cable. Everything works but the screen does not do anything. Whats wrong with it??
Does the screen light up but has no display, or is it not lighting up at all?

Do you have fans plugged into the LCD?

Do you have power plugged into the LCD?
 

wee2john

Baseband Member
Messages
50
Does the screen light up but has no display, or is it not lighting up at all?
Do you have fans plugged into the LCD?
Do you have power plugged into the LCD?
The screen lights up with the logo and details but is stuck on the same time fan speed, CPU temp and the logo is ment to flash. There are three fans plugged into the lcd. Yes the cable is connected (double ended 4 pin connector) with one end connected to the PSU cable (other end does not fit)
 

Russel1

Daemon Poster
Messages
1,037
Did you get any kind of documentation with the computer case? I check the website but couldn't find any manual expaining how to change modes.
 

wee2john

Baseband Member
Messages
50
just a very basic one that tells you where the cables are plugged into (already plugged in, checked and checked again) and features of the screen
 

Russel1

Daemon Poster
Messages
1,037
Most computers have an On/Off button and a Reset button on the front, does your have any other buttons?
 

wee2john

Baseband Member
Messages
50
no just 'set' '+' '-' all connections are working but the lcd screen does not seem to do anything
 
Top