USB mouse not detected? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-12-2008, 03:51 AM   #1 (permalink)
Super Techie
 
Join Date: Mar 2006
Posts: 326
Default USB mouse not detected?

Hey all,

Just did a reformat on my PC and when I get into windows my USB mouse is not detected. It worked fine before the format. I have USB mouse support enabled in BIOS. When I throw a PS/2 adapter on the mouse it works. But when I turn off the PC the mouse still stays lit up. I tried a couple other USB mice and the same thing happened.

I should be fully updated to SP3 running XP pro. Is there a certain file that runs the mouse? Any ideas on a fix?
__________________

Shafra is offline  
Old 08-12-2008, 04:05 AM   #2 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,507
Default Re: USB mouse not detected?

Have you made sure to install all the updated drivers? Especially chipset drivers?
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline  
Old 08-12-2008, 04:22 AM   #3 (permalink)
Super Techie
 
Join Date: Mar 2006
Posts: 326
Default Re: USB mouse not detected?

Yes, I installed all drivers from my motherboard CD right after the XP install. I'm using a Mouseman Wheel by Logitech. I've used it on 4 PC's without ever needing to install drivers for it. Didn't see drivers for it on the Logitech site. When I plug the mouse into the USB port it does light up but will not function. It just feels like I need some type of USB mouse drive installed. I did verify I am updated through service pack 3.


Any other ideas are appreciated.
Shafra is offline  
Old 08-12-2008, 12:43 PM   #4 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: USB mouse not detected?

Hello,

the chipset drivers control the USB Ports. So if the chipset driver was on the disk then you should be all set. If not find a updated version for your motherboard.

Cheers,
Mak
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 08-12-2008, 02:14 PM   #5 (permalink)
Super Techie
 
Join Date: Mar 2006
Posts: 326
Default

Thanks, I found an updated driver for the chipset. I reinstalled it, rebooted, and this time it said "missing file "mouhid.sys" . I scanned on my other PC and found it in the windows/system32/drivers folder. However, I was hard locked on the machine I'm having trouble with, keyboard would not work. I rebooted and used PS/2 mouse, went into XP and copied the mouhid file into the system32/drivers directory. Reinstalled chipset drivers, rebooted, and mouse still did not work.

This is a fresh install and it seems like windows did not install some drivers for USB support it was supposed to or something. Any other ideas? Was I supposed to copy the mouhid.sys file to another directory?

Hey guys, I wanted to finalize the post. I copied the mohid.sys file to the windows/drivercache/i386 folder and then reinstalled chipset and rebooted and this time it detected the USB mouse. What a pain in the butt. But it's working now, and the mouse lights actually turn off when the system is powered down.

Thanks for the help! The chipset driver reinstall was the key to figuring out what file was missing so could not have figured it out without the tip.
Shafra is offline  
Old 08-12-2008, 07:22 PM   #6 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,507
Default Re: USB mouse not detected?

Well at least you managed to get it working. Glad to know it works now.
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Mouse not responding? Desperate, Help Please! HELPMEPLZ Hardware Repairs and Troubleshooting 1 06-11-2008 12:24 AM
new computer overheating jokka37 Hardware Repairs and Troubleshooting 8 05-23-2008 02:36 AM
crashing pc daz6215 Overclocking and Modding 6 02-29-2008 12:35 PM
New PC Mouse doesn't work, conflicrs with USB Ioanni Hardware Repairs and Troubleshooting 6 02-26-2008 03:51 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.