DVD Drive not detected on new build - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 03-07-2007, 08:37 AM   #1 (permalink)
Newb Techie
Join Date: Jan 2007
Posts: 7
Default DVD Drive not detected on new build

My motherboard is the P5B-E and this is the DVD Drive:


I've tried the setting the jumper in all 3 places. The power connection is fine as I can open the drive while it's on. Also, I'm using the IDE cable that came with my motherboard and it says "HDD Cable" on it. However, it fits in the DVD Drive just fine. Will it only work with Hard Drives though?

S. Famous is offline  
Old 03-07-2007, 10:19 AM   #2 (permalink)
True Techie
Join Date: Jun 2006
Posts: 139

Hi. Does your DVD drive show in Device Manager or your BIOS? That IDE cable you're talking about, do you have your Hard Drive connected to it and you're trying to connect your DVD as a Slave? or that's the cable corresponding to the second IDE connector on your Motherboard? Post back with more info,please.

\"You just don\'t live life. You change it. You shape it. You make a mark upon it...\"
COCOCOOKIE is offline  
Old 03-07-2007, 02:31 PM   #3 (permalink)
Newb Techie
Join Date: Mar 2007
Posts: 37

So you can open and close the DVD door? But it will not show up on "My Computer", so it's not detected? What about the device manager?
Tcm9669 is offline  
Old 03-07-2007, 09:06 PM   #4 (permalink)
Newb Techie
Join Date: Jan 2007
Posts: 7

I haven't even installed an OS yet. Apparently a lot of people have had problems with the motherboard not detecting IDE drives because of the JMicron chip on the 965 motherboards. The DVD drive is the only one connected through IDE, my HD is using SATA. I've done some reading and it seems I can fix it through updating the BIOS. However I have no way of doing this because I have no floppy or any other drive. Any ideas?


Well, I feel foolish now. I never bothered to try the drive. So the only problem is getting BIOS to show that it's recognized, while the drive itself will actually work. Windows is installing now and I'll update everything too see if that takes care of it. Thanks for the replies.
S. Famous is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:13 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.