HDD Light stays on and PC monitor stays on standby

Status
Not open for further replies.

Domestic

In Runtime
Messages
178
PC has been working fine for years but suddenly last night it froze, I was just using Photoshop and when I reset the monitor would stay at standby and the HDD light would stay on.
I cleared out a little bit of dust on the motherboard, took the mobo battery out and put it back in, made sure everything was plugged in and everything seemed normal but the problem remains.
I'm guessing the motherboard has kicked the bucket but not sure.
Thanks in advance to anyone able to offer advice.
 
well, the symptoms imply that the computer isn't passing POST. so that makes the most likely culprits the memory, cpu and motherboard. check that the memory is seated properly, the cpu heatsink is mounted properly and the fan is connected and then you can start thinking about blaming the board. if you have spare memory and/or a spare cpu they might come in handy to rule things out.

edit: it could also be the graphics card but it's less likely. if you don't have access to another computer/graphics card, try taking the current one out and seeing if the HDD light still stays on while trying to boot without it. now i'm presuming you have a basic knowledge of ESD and handling computer parts.
 

Domestic

In Runtime
Messages
178
well, the symptoms imply that the computer isn't passing POST. so that makes the most likely culprits the memory, cpu and motherboard. check that the memory is seated properly, the cpu heatsink is mounted properly and the fan is connected and then you can start thinking about blaming the board. if you have spare memory and/or a spare cpu they might come in handy to rule things out.

edit: it could also be the graphics card but it's less likely. if you don't have access to another computer/graphics card, try taking the current one out and seeing if the HDD light still stays on while trying to boot without it. now i'm presuming you have a basic knowledge of ESD and handling computer parts.
Cool, thanks for the fast response. I have got a spare gfx card and memory so I will try and start ruling things out.

edit:sorry to double post but I should also mention that the "beep" noise is being made on start up like usual either.
 

Domestic

In Runtime
Messages
178
sorry to double post but I should also mention that the "beep" noise is being made on start up like usual either.
 

Domestic

In Runtime
Messages
178
Messed around, tried heaps of different stuff and eventually surrendered and have given it to a local repair guy to see if he is able to identify the problem.
 

hikaricloud

Golden Master
Messages
6,220
Location
USA
There's an easy test you could have done to see if your mobo was done for: take out your RAM, then turn the machine on. If it beeps at you like crazy, your mobo may still be salvageable. If it stays silent, time to replace that bad boy.
 
Status
Not open for further replies.
Top Bottom