Techist - Tech Forum

Techist - Tech Forum (http://www.techist.com/forums/)
-   Microsoft Windows and Software (http://www.techist.com/forums/f9/)
-   -   L101010101010101... (http://www.techist.com/forums/f9/l101010101010101-14287/)

JohnM 04-13-2004 11:03 AM

L101010101010101...
 
This problem has probably been addressed on this forum a zillion times, but I'm a newbie here...

I need help.

I broke my MBR and cannot seem to fix it. My principal HD is a RAID 0 configuration, which is normally my boot disk (2 ATA SG Barracuda 80’s). It is also where my WinXP is installed. (Single OS on this disk). I installed SuSE 8.2 on a separate HD, and setup a dual boot with LILO. For some reason known only by GOD I chose to manipulate the MBR. “Why would you do that?” Good question. Anyway, needless to say, XP is unbootable. (I get the L101010101010101010101010…)
I’ve tried everything to recover the MBR, but cannot. I boot with the XP disk, (config my raid drivers via F6) go to recover, try every tool available, nothing. Fixmbr and Bootfix run OK, but I always end up at the 101010101010 screen. There is no reference to Linux or LILO in my boot.ini file. Everything seems in order, but every time I try to open XP, 101010101010…
Someone – anyone – please help me fix my MBR!

killians45 04-13-2004 03:05 PM

problem is fixmbr doesn't fix anything from bios bootstrap, it just the fluff after it. not sure what you mean by 'manipulate', what did you do? sounds like linux kernal problem. maybe HD controller error?

JohnM 04-13-2004 03:32 PM

I don't think the problem is on the Linux side - it boots up fine. What I mean by manipulate is that during the Linux installation, it gave me the option to write new boot configuration to the MBR, which I opted to do. Found out that this is not a good idea.
I know that XP doesnt like to treated as an optional OS to load (in the MBR anyway), and always assumes that it is the only OS in any one given installation. But after all attempts to fix the MBR, I cannot undertand how I still cannot reboot. I have physically disconnected all my other HD's, reconfigured my BIOS, deleted everything in my root directory (except for the necessary IO, DOS, Config, and Boot files), ran every available tool in the Recovery mode of XP, and still get those little f****** 1s and 0s from LILO. This is not the first time I've used LILO, but its the first time my MBR has been so screwed. Think I'll have to reinstall XP. Uuuugh.


Please excuse me while I go shoot myself in the foot.

killians45 04-13-2004 05:01 PM

Man, I just keep reading over and the fixboot should of adjust the ntloader in the boot.ini file. It does look like you may need to reinstall, though. Hell, may even want to write 0's! Ill see what else I can come up with.

killians45 04-13-2004 05:07 PM

also, is it displaying LI01010101010 or is it L1010101010 (as in LI or L1)

killians45 04-13-2004 05:15 PM

Try this

Insert the CD of XP and then restart the machine .
Go into Bios and change the boot sequence so that your machine starts from the cdrom drive .
Boot from CDrom and when the menu appers press the right button the says fix an existing installation .After you do this login as Admyn.It will ask propably for a password but not neccesseraly.Then at the prompt do the following:
1.Type the command fixmpi.it will ask you something answer yes
2.Type the command fixboot.it will ask you something answer yes
after these type restart
insert into bios and change the boot sequence and make it to boot from the hard disk .This wiil fix the bootsector of your windows and you will be able to boot windows but not linux .For the linux try simply to update and the installation by adding some packages and when prompted to write loader at the disk say now then it will ask you to create a bootdisk DO that so you can boot from a diskete the linux partition .

....maybe this will help, I dunno

JohnM 04-14-2004 08:33 AM

Thanks for the insight, but I think I'm just going to give up and not use computers anymore. Maybe I'll move to Bolivia and pick beazle nuts for a living or something. (Sigh.)

Or not. Your suggestions are pretty much aligned with what I have done. (Except for "fixmpi". What's that? Do you mean Fixmbr?) I have decided not to re-install XP. Actually, I refuse to reinstall it. That would be the easy way out. I am going to resolve this issue, if not merely out of curiosity. I'll let you know how it goes. As for the Linux side, what's done is done as far as the MBR is concerned. I have a boot disk, and I can reconfigure LILO at will, but I cannot recuperate the original configuration of the MBR. I can un-install LILO, install GRUB, configure it, change it, talk nicely to it, but it won't fix my MBR. I did not have to change the MBR to begin with. I could have recorded the LILO boot sector on my 3rd or 4th HD, created its own partition, or loaded it directly onto my principal RAID configuration, (p0 or p1) and everything would have been fine. But I went a step further and wrote changes to my MBR. Why? Because it asked me if I wanted to, and provided me a nice little check box to say YES. (Actually, I had no intention of re-configuring it later, thinking it would be my final boot configuration, and so felt confident that I wanted to record it in my MBR. stupid move.)
i WILL suceed.
Still open to suggestions though.
Thanx again.

______________________________
Its better to keep your mouth shut and appear to be an idiot than to open it and prove it so.

killians45 04-14-2004 04:32 PM

how about just keeping the MBR as is and set a pointer to XP? Reinstall Linux and then add the boot manager to the MBR and I would think later versions of linux should be able to add XP to the boot menu. Or someone has suggested using GRuB

killians45 04-14-2004 04:34 PM

oh, sorry, the fixmpi was from another forum and found it. I believe its to fix the master partition index.

JohnM 04-15-2004 12:55 PM

And the good news is....

Firstly, many thanks for all your help, Killians. You give good advice.

And at long last, Problem Resolved. Comp 0, John 1. I consulted with our in-house tech geeks, and they recommended a site with great tools. This version of Fixmbe did the trick. I've attached the links below. Good tools to keep in your toolbox for those who tinker.
Thanks again k45! See ya 'round!

http://www.diydatarecovery.nl/~tkuurstra/repairmbr.htm
http://www.ntfs.com/mbr-damaged.htm
http://www.wown.com/j_helmig/wxprcons.htm


All times are GMT -5. The time now is 05:37 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.