AutoRun stopped working - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Microsoft Windows and Software
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 11-29-2006, 06:05 AM   #1 (permalink)
Newb Techie
 
Join Date: Nov 2006
Posts: 1
Default AutoRun stopped working

Out of nowhere i realised that autorun/autoplay on my optic drivers stopped working. I haven't made a major change on anything. It also works 100% when i right click the driver on My Computer and select AutoPlay. Why did this happen and how can i take it back to make autorun active again?
Thanks in advance.

OS is Windows XP Pro
__________________

blazetrk is offline  
Old 11-29-2006, 08:37 AM   #2 (permalink)
Junior Techie
 
twopointshotdr's Avatar
 
Join Date: Nov 2006
Posts: 66
Send a message via AIM to twopointshotdr
Lightbulb this should do it....

hey....usually this problem is caused by outdated cd rom drivers...incompatible cd drivers with xp or seldomly if roxio easy cd creator with an olllldd version is installed. like something before version 5.02d. if thats the case just remove or update the program. all of this is strange anyways...because you said it worked before correct? well anyways....

if the program thing is not the culprit, then what we'll need to is edit the registry.

1st off...I WILL NOT BE HELD ACCOUNTABLE FOR A SCREWED UP REGISTRY JUST BECAUSE YOU DIDNT WANT TO BACK IT UP FIRST BEFORE YOU START EDITING.

if you simply dont care well then lets begin....OOH YEA BY THE WAY...the cd autorun also wont work if your not logged in under admin or power users group.

so on to the registry editing...

a. Click Start, and then click Run.
b. Type regedit, and then click OK.
c. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\CDRom
d. Do one of the following:
• If the value for Autorun is 1, go to step 3-e.
• If the value for Autorun is 0, right-click Autorun, and then click Modify. In the Value data box, type 1, and then click OK.

e. Locate and then click the following subkey:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer
f. Look at the value of the NoDriveTypeAutoRun entry. A value of 0xb5 turns off the AutoRun feature for CD-ROMs. To turn on the AutoRun feature, right-click NoDriveTypeAutoRun, click Modify, type 91 in the Value data box, select Hexadecimal, and then click OK.
g. Quit Registry Editor.


ALSSOOO....IF THAT DIDNT WORK.....

Verify that the Restrict CD-ROM access to locally logged on user only option is not turned on.
a. Click Start, click Run, in the Open box, type regedit, and then click OK.
b. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
c. In the right pane, under Data, if the value for allocatecdroms is 0, go to step 5.
d. In the right pane, under Data, if the value for allocatecdroms is 1, right-click allocatecdroms, and then click Modify.
e. In the Value data box, type 0, and then click OK.
f. Quit Registry Editor.

If AutoRun is turned on in the registry, make sure that your CD-ROM driver is current:
a. Click Start, right-click My Computer, and then click Properties.
b. On the Hardware tab, click Device Manager.
c. In Device Manager, expand DVD/CD-ROM drives, and then right-click the CD-ROM drive that you want to update. Click Update Driver to start the Hardware Update Wizard, and then follow the instructions that appear on the screen to install the latest driver for your CD-ROM drive.

Test to determine whether the issue is resolved. If the issue is resolved, do not complete the remaining step. If the issue is not resolved, go to step 6.
__________________

__________________
My build:
GIGABYTE GA-M57SLI-S4 AM2 NVIDIA nForce 570 SLI
AMD Athlon 64 X2 6000+ Windsor 3.0GHz
CORSAIR XMS2 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (4GB TOTAL)
CORSAIR CMPSU-620HX ATX12V 620W PSU (3 12v Rails)
Western Digital Caviar 250GB 7200 RPM 16MB Cache SATA 3.0Gb
Western Digital Caviar 160GB 7200 RPM 8MB Cache SATA 3.0Gb
Thermaltake Armor Series Black Full Tower Case w/ 25CM Fan
PNY GeForce 8800GTS 640MB 320-bit GDDR3


--It's really not that complicated--
twopointshotdr is offline  
Old 11-30-2006, 12:04 PM   #3 (permalink)
True Techie
 
Join Date: Nov 2006
Posts: 112
Default

Before you go editing your registry, just go into MY COMPUTER and RIGHT CLICK the drive and choose PROPERTIES. Then go to the AUTOPLAY tab and enable it. Now Autoplay will work when you put a CD/DVD in.
__________________
Joe
<a href=\"http://www.technogab.com\">Technogab Podcast</a>
<a href=\"http://phobos.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=196334747\">Subscribe via Itunes</a>
<a href=\"http://feeds.feedburner.com/technogab/feed\"><img src=\"http://feeds.feedburner.com/technogab/feed.gif\" style=\"border:0\" alt=\"TechnoGab Podcast\"/></a>
technogab is offline  
Old 11-30-2006, 01:49 PM   #4 (permalink)
Junior Techie
 
twopointshotdr's Avatar
 
Join Date: Nov 2006
Posts: 66
Send a message via AIM to twopointshotdr
Default

hes tried that already....he wants to make it his default option....some reason why its not sticking when he/she goes into my computer and enables it.
__________________
My build:
GIGABYTE GA-M57SLI-S4 AM2 NVIDIA nForce 570 SLI
AMD Athlon 64 X2 6000+ Windsor 3.0GHz
CORSAIR XMS2 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (4GB TOTAL)
CORSAIR CMPSU-620HX ATX12V 620W PSU (3 12v Rails)
Western Digital Caviar 250GB 7200 RPM 16MB Cache SATA 3.0Gb
Western Digital Caviar 160GB 7200 RPM 8MB Cache SATA 3.0Gb
Thermaltake Armor Series Black Full Tower Case w/ 25CM Fan
PNY GeForce 8800GTS 640MB 320-bit GDDR3


--It's really not that complicated--
twopointshotdr is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.