Lenovo T61 screen issue - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Laptops and Notebooks
Closed Thread
Thread Tools Display Modes
Old 06-09-2011, 08:03 PM   #1 (permalink)
Super Techie
Join Date: Mar 2004
Posts: 276
Default Lenovo T61 screen issue

My laptop has suddenly developed a screen issue. Out of the blue one day I noticed the bottom of my screen start to fade to white up the screen. While this would happen, the screen would become unresponsive. The computer was still working behind the scenes, just the display was messing up.
Over a day or so, it stopped the fade to white issue and just started freezing up with white horizontal lines across the screen.
I can get it to work by adjusting the lid to a different angle or pressing in on the back of the lid. Once it's in a good position the computer works perfectly, I just can't adjust the screen in any way. Slight movement (from typing etc) does not make a difference, but actually moving the lid freezes is up. Otherwise the display is perfect.

Not sure if a video of the issue would help.....I will upload and edit with link in a minute.....

Here we go -


canooten is offline  
Old 06-09-2011, 08:10 PM   #2 (permalink)
Techie Beyond Description
MindoverMaster's Avatar
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Lenovo T61 screen issue

Hook up an external monitor. If that works fine, it is the lcd cord that is loose.

Neowin.net Steam Account
MindoverMaster is offline  
Old 08-20-2011, 10:00 AM   #3 (permalink)
Super Techie
Join Date: Mar 2004
Posts: 276
Default Re: Lenovo T61 screen issue

External output is fine, so the problem is definitely in the display.

I was finally able to fully remove the LCD panel and check the ribbon cable connection. It seemed tight to begin with....the tape that holds the connection was intact, but I removed it anyway and reseated all connections. The problem is still there and has gotten worse over the last several weeks.

Should I assume that the issue is the ribbon cable itself? The panel seems fine....once I finagle it into the right position it works great. Getting there involves pressing near where the cable connects to the panel and setting the screen at a just-so angle.
canooten is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
blank screen - hdd issue? thomagreg Hardware Repairs and Troubleshooting 6 02-02-2009 09:05 AM
Screen Issue. patonb Laptops and Notebooks 3 09-28-2007 12:58 PM
Blue Screen Issue sanderson81 Microsoft Windows and Software 4 07-10-2006 03:02 PM
Dual screen issue. starforsaken Microsoft Windows and Software 5 12-14-2005 07:15 PM
WMP full screen issue 2Guido Microsoft Windows and Software 1 03-20-2004 08:35 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:58 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.