Help with my x800xl - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Monitors, Printers and Peripherals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 04-20-2005, 07:57 PM   #1 (permalink)
Super Techie
 
Join Date: Mar 2005
Posts: 314
Default Help with my x800xl

I need help, when I try to put my x800xl into my dfi nf4 ultra mobo it won't fit right. I can get it to slide in but I am having trouble getting the back where the metal plate is to be snug against the case therefore I cannot even fit a screw in. It looks like its just a little above and to the side of where its supposed to be. Ive tried applying pressure but it doesn't help any. I think it has something to do with the fan on the mobo. There is this little fan on the gpu on the mobo that the card hits when I try to put it in. I have tried both pci-e slots but none will work. The card also looks slightly bent, I blame the shipping because newegg put it in a box with the other stuff, and instead of coming in a case they just took the stuff out and sent it in bubble wrap crammed with everything else. Any suggestions on how I can get this to fit?
__________________

Vampire_Slayer is offline  
Old 04-20-2005, 08:01 PM   #2 (permalink)
Wizard Techie
 
Join Date: Feb 2005
Posts: 3,220
Default

you can't just slide it in, you gotta use some force to push it in

if it breaks, then ship it back to newegg and tell them it was DOA/broke during shipping and blame it on them; newegg will immedaitely send you out a new one
__________________

__________________


Quote:
I don\'t play for fun, I play to win and winning is fun.
diabloII is offline  
Old 04-20-2005, 08:03 PM   #3 (permalink)
Super Techie
 
Join Date: Mar 2005
Posts: 314
Default

I did use force, it goes most of the way in, and I am afraid to use too much pressure on it since I am already using quite a bit.
Vampire_Slayer is offline  
Old 04-20-2005, 08:04 PM   #4 (permalink)
Ultra Techie
 
Join Date: Mar 2005
Posts: 587
Send a message via AIM to Sport1031
Default

I know I'm treating you like a n00b but are you sure you have a PCI-E card and mobo.

Make sure your mobo is mounted correctly. If you installed the mobo, make sure the standoffs are all the way in. I had that problem. If they aren't, it will cause this problem. Nothing lines up right.
Sport1031 is offline  
Old 04-20-2005, 08:15 PM   #5 (permalink)
Super Techie
 
Join Date: Mar 2005
Posts: 314
Default

Well I got it lol.......Ended up going back and messing around a little bit more.....Sorry I put you guys through this, should have messed around some more.....Ok, I'm gonna plus in the cables and start her up
Vampire_Slayer is offline  
Old 04-20-2005, 08:19 PM   #6 (permalink)
Super Techie
 
Join Date: Mar 2005
Posts: 314
Default

I don't want to make another thread, so before I start her up, if I take off the heatsink to check to see if the thermal compound is on right(this artic stuff makes you put a dab on it and let the heatsink spread it and mine was more of a mess) will I have to wash it off and put more on it? I heard you usually do this when you remove your fan.....
Vampire_Slayer is offline  
Old 04-20-2005, 08:31 PM   #7 (permalink)
Lord Techie
 
Join Date: Jan 2005
Posts: 8,013
Send a message via AIM to DJ-CHRIS
Default

No dont worry about it, expisally if you may RMA

After your card works, worry about it
DJ-CHRIS is offline  
Old 04-20-2005, 08:58 PM   #8 (permalink)
Monster Techie
 
Join Date: Jan 2005
Posts: 1,019
Default

hey dont be ashamed.. i remember it took me about 30minutes to get my 56k modem in.. those things are a b1tch.. i bent it in half and had to bend it back and everything
__________________
Sig reinstated. SigSanta
VIII is offline  
Old 04-20-2005, 09:12 PM   #9 (permalink)
Monster Techie
 
Join Date: Feb 2005
Posts: 1,363
Default

You think that's embarrasing? It took me 2 whole days to put a sound card in my old PC. I was 12 years old. . lol.
__________________

__________________

Quote:
Ricer: from the latin word Ricarius meaning to suck at everything you attempt.
desiboi is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.