Video card help. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-23-2006, 11:06 PM   #1 (permalink)
Newb Techie
 
Join Date: Jan 2006
Posts: 34
Default Video card help.

I installed 6600gt 128megs to replace ati 9250 256megs and i'm getting black screens on several games and demos.

Like Stubbs zombie demo, game loads and all but can't see anything. I'd tried it on a 6200 i'd bought and returned and that one also did the black screen.

Heres my specs.

p4 2.53 ghz 1 gig ram on windows xp with the brand new 84.25 drivers for nvidia.
__________________

Sleepyz is offline  
Old 03-23-2006, 11:11 PM   #2 (permalink)
Monster Techie
 
Join Date: Sep 2005
Location: N/A
Posts: 1,486
Default

Did you clean out the old ATI drivers? If you didn't then thats your problem. Download a program like drivercleaner or something.
http://www.drivercleaner.net/
__________________

Vybuni is offline  
Old 03-23-2006, 11:33 PM   #3 (permalink)
Newb Techie
 
Join Date: Jan 2006
Posts: 34
Default

hadn't thought of that so went to add/remove and removed everything ATI and nope so downloaded that program and removed everything ATI with it and still get black screen.
Sleepyz is offline  
Old 03-24-2006, 12:59 AM   #4 (permalink)
Monster Techie
 
Join Date: Sep 2005
Location: N/A
Posts: 1,486
Default

Try uninstalling all drivers and reinstalling the nvidia ones. Also try an older one, like 81.98 or something.
http://downloads.guru3d.com/download.php?det=1282
They have a lot of drivers on that site.
Vybuni is offline  
Old 03-24-2006, 01:14 AM   #5 (permalink)
Newb Techie
 
Join Date: Jan 2006
Posts: 34
Default

It is working now. Just installed Fear MP demo and ran great. My old ati 9250 256meg would of never ran it that nice.

Only stubbs the zombie now still does black screen but checked message board and i'm not the only one. Game seems badly designed. Shame was thinking of buying it.

Anyway thanks for the help. Removing all evidence of ati seemed to do the trick.
Sleepyz is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.