Old(ish) full tower in need of some TLC. Help please. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 02-05-2013, 09:17 AM   #1 (permalink)
Newb Techie
 
Join Date: Feb 2013
Location: U.S.
Posts: 4
Default Old(ish) full tower in need of some TLC. Help please.

Okay so I have been in the market for a new PC and I got my dad to give me his old one that he never uses anymore. It's a full tower with an Intel extreme 915p pf4 motherboard, I'm not sure about the graphics card but I know when he bought it, it was one of the nicest, so he says. 4 sticks of 4gb ram I believe, A 500w power supply and a Intel i7 processor.

Now the problem is that it has about a year or so worth of dust on it, I plan on getting an aerosol can and cleaning it all off. I don't know if dust would be a factor but I'm not getting anything to the monitor(s) he gave me with it through HDMI or DVI. It turns on and it sounds like everything is running but for the life of me I can't get it to display anything. He thinks that a while ago the HD crapped out and I need a new one but I'm suspicious of the motherboard itself. Is there anyway I can figure out just what exactly is wrong with it before I go spending hundreds of dollars on hardware I might not need? I can supply pictures if needed. Thanks for any help.
__________________

Thomkids is offline   Reply With Quote
Old 02-05-2013, 10:14 AM   #2 (permalink)
Wizard Techie
 
Join Date: May 2011
Posts: 3,077
Default Re: Old(ish) full tower in need of some TLC. Help please.

Is this your board?
Newegg.com - Open Box: ECS PF4 Extreme LGA 775 Intel 915P ATX Intel Motherboard

from ECS:
ECS Web Site > PF4 Extreme (V1.0)

We need to know more about your graphics card, brand name and model. This motherboard does not have on-board video
__________________

Joe C is offline   Reply With Quote
Old 02-05-2013, 10:37 AM   #3 (permalink)
 
patonb's Avatar
 
Join Date: Jan 2005
Location: In Gov't Regulated Cubical
Posts: 9,745
Default Re: Old(ish) full tower in need of some TLC. Help please.

Even with a bad hard drive a computer will boot to the BIOS.

Does it POST Beep? A compuer will beep once if it passes its start up tests.

There's a problem with your "I think it has..." as the boards a 775 socket but i7 don't come in that socket.

Yuo need to clean it up, and reset all the parts before we can see if its booting or not.
__________________
Foldie = i5 6600kMSI Z170A M5 EVGA 970 SC Corsair H100 Corsair hx520 2x8gb GSkill Corsair 650D
Woohoo = L5639 @3.1Ghz EVGA SR-2 gtx 260-216 Hyper 212+ Corsair 1050hx 6x2gb Corsair XMS3 Blackhawk Ulra
Alienware 18 - SLI 770M 4700mq 16Gig

patonb is offline   Reply With Quote
Old 02-05-2013, 03:03 PM   #4 (permalink)
Newb Techie
 
Join Date: Feb 2013
Location: U.S.
Posts: 4
Default Re: Old(ish) full tower in need of some TLC. Help please.

Yes that is my motherboard. Sorry I wasn't sure what specifically you needed to help me, I'll give as much info as I can. You're right, talked to my dad and he said he never did get an i7. The video card is a Sapphire Radeon HD 4650 1GB. Sorry for being so vague before I hadn't really gotten time to take it all apart. And no there is no POST beep sound. I can hear the HD turning but thats about it. I also removed all the RAM, made sure it was clean and reconnected them all. That Didn't help either but at least I know it isnt the RAM.
Thomkids is offline   Reply With Quote
Old 02-05-2013, 03:23 PM   #5 (permalink)
True Techie
 
Multicore's Avatar
 
Join Date: Sep 2012
Posts: 101
Default Re: Old(ish) full tower in need of some TLC. Help please.

I encountered a nearly identical problem - the battery (CR-3032) was depleted.
After putting a new battery (or button cell, as some say) the computer worked fine.
This is just a pointer to check the button cell.

ps. The computer sat unused for 10 months at a stretch.
Multicore is offline   Reply With Quote
Old 02-05-2013, 03:38 PM   #6 (permalink)
Newb Techie
 
Join Date: Feb 2013
Location: U.S.
Posts: 4
Default Re: Old(ish) full tower in need of some TLC. Help please.

You think if it turns on it still needs that changed? I'm probably just going to go ahead and upgrade the MOBO and the processor to a AMD 4100, not sure about the MOBO though. Any suggestions would be a great help.
Thomkids is offline   Reply With Quote
Old 02-05-2013, 04:04 PM   #7 (permalink)
 
patonb's Avatar
 
Join Date: Jan 2005
Location: In Gov't Regulated Cubical
Posts: 9,745
Default Re: Old(ish) full tower in need of some TLC. Help please.

I'd say popping out the battery for 30 seconds then retrying may help.

The photos of the board look like they have a speaker, so no beeps = somethings not booting and its not the gpu.

Disconnect the drives and try it out...
__________________
Foldie = i5 6600kMSI Z170A M5 EVGA 970 SC Corsair H100 Corsair hx520 2x8gb GSkill Corsair 650D
Woohoo = L5639 @3.1Ghz EVGA SR-2 gtx 260-216 Hyper 212+ Corsair 1050hx 6x2gb Corsair XMS3 Blackhawk Ulra
Alienware 18 - SLI 770M 4700mq 16Gig

patonb is offline   Reply With Quote
Old 02-05-2013, 07:49 PM   #8 (permalink)
Newb Techie
 
Join Date: Feb 2013
Location: U.S.
Posts: 4
Default Re: Old(ish) full tower in need of some TLC. Help please.

So far nothing has worked. If it truly is the HD would that stop it from booting at all?
Thomkids is offline   Reply With Quote
Old 02-05-2013, 09:29 PM   #9 (permalink)
 
patonb's Avatar
 
Join Date: Jan 2005
Location: In Gov't Regulated Cubical
Posts: 9,745
Default Re: Old(ish) full tower in need of some TLC. Help please.

No the computer first boots to the boards bios, then fires up the hard drive.

you should unplug the drive and see what happens.
__________________

__________________
Foldie = i5 6600kMSI Z170A M5 EVGA 970 SC Corsair H100 Corsair hx520 2x8gb GSkill Corsair 650D
Woohoo = L5639 @3.1Ghz EVGA SR-2 gtx 260-216 Hyper 212+ Corsair 1050hx 6x2gb Corsair XMS3 Blackhawk Ulra
Alienware 18 - SLI 770M 4700mq 16Gig

patonb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.