New hardware upgrade issues. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 12-19-2014, 02:56 PM   #1 (permalink)
Newb Techie
 
Join Date: May 2014
Location: England
Posts: 13
Default New hardware upgrade issues.

Hi guys,

I had an issue with my PC where when I pressed the on button, the fans would spin and the LED's would turn on but all just for a second. The weird part is that it would work every so often. It would take 15-20 minutes of just repeatedly turning it on, and trying again and again and eventually it would turn and work perfectly afterwards.

I ordered a new power supply, installed it, and now my issue is gone! Hooray! However, now when I turn it on, although turning on every time without fail there is no display on either of my two monitors. The fans spin the LEDs light up, but as I said there is no display. I'm really confused because as I said it was working just the previous night (after a few attempts at turning it on)

Hardware:
Corsair 750 bronze modular PSU
Palit Nvidia GEFORCE GTX 650 GPU
AMD A8-6600K 3.6ghz CPU
GIGABYTE GA-F2A55M-HD2 motherboard
__________________

spoonjarspoon is offline   Reply With Quote
Old 12-19-2014, 06:13 PM   #2 (permalink)
Newb Techie
 
Join Date: Dec 2014
Location: Pennsylvaia
Posts: 9
Default Re: New hardware upgrade issues.

Try unplugging and re-plugging your display cables. If that doesn't do anything, try just one monitor. Also, don't forget to plug in all of your PSU cables but i doubt you didn't check that. If none of this works, well.... sorry i wasted your time :P
__________________

Arkstar0 is offline   Reply With Quote
Old 01-05-2015, 07:45 AM   #3 (permalink)
Monster Techie
 
rulezero's Avatar
 
Join Date: Jan 2015
Location: Earth
Posts: 1,685
Default Re: New hardware upgrade issues.

Make sure your GPU seated properly on the mobo and if you have a spare PC put your GPU in it and make your sure GPU is not damaged.
rulezero is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New PC hardware upgrade? TheByt3 New Systems | Building and Buying 0 07-21-2010 09:38 PM
Issues issues issues. Vista-64bit. 9600GT's in SLI. 4GB Vista problems. Oy Vey. TheOtis Hardware Repairs and Troubleshooting 2 03-24-2008 12:59 PM
Hardware problem [not sure what hardware] TecĀµ Hardware Repairs and Troubleshooting 0 09-14-2005 10:20 PM
modding loud hardware into quiet hardware waynejkruse10 Overclocking and Modding 7 04-22-2005 09:47 PM
Making external hardware out of internal hardware Blunty Overclocking and Modding 3 03-08-2004 08:03 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.