Network card issues - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-24-2014, 02:34 PM   #1 (permalink)
Newb Techie
 
Join Date: Jun 2014
Location: Hermann
Posts: 5
Exclamation Network card issues

I've had this problem now for about 2 years and nothing seems to fix it:/
Every 20/30-ish minutes my pc disconnects from the internet and only reconnects when i click troubleshoot problems and wait for 2 minutes.
My network card is an Atheros AR938x and my drivers are up to date.
Ive tried reinstalling the network card, turning off "allow computer to turn this off to save energy" and a lot more, but still the problem isn't resolved.
(I suspect that the card is broken but the device manager tells me it works fine)
Please, clever forum members, help me repair this!
__________________

the99o is offline   Reply With Quote
Old 06-24-2014, 02:42 PM   #2 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,515
Default Re: Network card issues

Assuming this is a wifi card?

If so, then are there any devices in the way of your router/computer that would cause interference, such as a cordless phone, microwave, etc?
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Old 06-24-2014, 02:46 PM   #3 (permalink)
Newb Techie
 
Join Date: Jun 2014
Location: Hermann
Posts: 5
Default Re: Network card issues

good idea, but i dont think so. i should have mentioned that the other computers/devices
in the network arent having any trouble.

PS: i Just updated the driver a few hours ago and it still happens but somehow now i dont need to troubleshoot, but still i disconnect every 20 minutes:/
the99o is offline   Reply With Quote
Old 06-24-2014, 02:49 PM   #4 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,515
Default Re: Network card issues

Did you get the drivers directly from Atheros, or from your computer's manufacturer's site? If the latter, then go here and get the latest (assuming you have Windows 7): Drivers for Atheros AR938X and Windows 7

If the drivers from there don't work, and nothing is causing interference... then the easiest thing to do would be to just swap the wireless card out and see if the new one works or not.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Old 06-24-2014, 02:55 PM   #5 (permalink)
Newb Techie
 
Join Date: Jun 2014
Location: Hermann
Posts: 5
Default Re: Network card issues

got the drivers from that exact website. swapping the card may be easier said than done, because im running a windows 7 partion on my imac (problems occuring on both windows and mac) and id have to send it in for repair:/ perhaps ill try rebooting my pc AGAIN after updating the drivers.
the99o is offline   Reply With Quote
Old 06-24-2014, 03:07 PM   #6 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,515
Default Re: Network card issues

Does it do the same thing while booted into OSX? If so... then it's definitely a hardware issue. If it works fine in OSX but acting up in Win7... then it's a software/driver issue.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Old 06-24-2014, 03:09 PM   #7 (permalink)
Newb Techie
 
Join Date: Jun 2014
Location: Hermann
Posts: 5
Default Re: Network card issues

well not really the same thing. in osx it happens about every 3 hours or so and fixes itself in like 30 seconds. ill try some more stuff out and write on here again when i succeeded (or failed)
the99o is offline   Reply With Quote
Old 06-24-2014, 03:17 PM   #8 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,515
Default Re: Network card issues

But the point is that it still happens, right? IMO it's most likely a hardware issue.

If you want to be sure, try getting a USB wifi adapter and see if that does the same thing. That way you don't have to send it in (yet).
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BSOD issues with Killer Xeno Pro gaming network card. modibybob PC Gaming 0 01-03-2011 10:18 AM
Battlefield 2/gamespy ID issues, and mic issues. Help! Chad711 PC Gaming 14 09-07-2009 03:19 PM
Network Freezing in Vista Ult 64 - P5Q onboard network card. snowsurfer Computer Networking and Internet Hardware 2 03-01-2009 07:43 AM
Issues issues issues. Vista-64bit. 9600GT's in SLI. 4GB Vista problems. Oy Vey. TheOtis Hardware Repairs and Troubleshooting 2 03-24-2008 12:59 PM
Virus --> Sound Issues --> Reformat --> Still Sound Issues craw4d42 Hardware Repairs and Troubleshooting 1 02-09-2007 05:37 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.