Mouse problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-30-2011, 04:28 PM   #1 (permalink)
Newb Techie
 
Join Date: Jul 2011
Posts: 3
Default Mouse problem

Hello all,

Here's an issue I been trying to solve with my mouse at start-up.
When I first turn on the computer, for about 5 minutes the mouse can't move left, right, up and down.

I have the Razor NAGA gaming mouse on a big steel pad.
(The one with the number pad on the left side of the mouse.)

What I've done:
1. Cleaned the pad.
2. Blew into the optical part of the mouse softly to get rid of all the dust.

The problem still occurs after all of this which brings me here. I've read this mouse is great for gaming but also has a lot of issues.

Is it a Bios load setting that is wrong or just the mouse that needs to be replaced?
If there is any other option I'd be glad to try it.

Thanks
-Fian
__________________

fianftw is offline  
Old 07-30-2011, 04:34 PM   #2 (permalink)
Newb Techie
 
Join Date: Jul 2011
Posts: 3
Default Re: Mouse problem

Forgot to mention I've also switched it in all ports. Problem still occurs in all.
__________________

fianftw is offline  
Old 07-30-2011, 09:53 PM   #3 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,506
Default Re: Mouse problem

Have you updated the mouse's drivers? Or tried updating its firmware (if available from Razer)? This sometimes occurs with my Lachesis, but it works when I just unplug it and plug it back into the same port.

Also try updating your computer's chipset drivers.

If it still occurs after all of this, try it on a different computer and see if it has the same symptoms. If it does... RMA the mouse.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline  
Old 07-30-2011, 10:20 PM   #4 (permalink)
Super Techie
 
Thomas's Avatar
 
Join Date: Jun 2011
Location: NY USA
Posts: 384
Default Re: Mouse problem

Quote:
Originally Posted by carnageX View Post
try it on a different computer and see if it has the same symptoms. If it does... RMA the mouse.
+1 for This!
__________________
Pentium D 935 @ 4.0ghz
AsRock g31
Kingston HyperX T1, 4gb
Radeon HD 5670 @ 860mhz gddr5
Antec High Current Gamer 520
InWin Br665 matx
CyberPower Green CP1500 900W UPS
Acer 20" G205hl
Camera Canon PowerShot SX10is
Quote:
Originally Posted by KSoD View Post
1) Be Respectful Treat other members as you would have them treat you. This means no flaming, insulting, or belittling other members.
Thomas is offline  
Old 07-30-2011, 10:24 PM   #5 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,506
Default Re: Mouse problem

Quote:
Originally Posted by Thomas View Post
+1 for This!
It could be the firmware if it hasn't been updated tho, either. So that should be tried first .
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline  
Old 07-30-2011, 10:30 PM   #6 (permalink)
Super Techie
 
Thomas's Avatar
 
Join Date: Jun 2011
Location: NY USA
Posts: 384
Default Re: Mouse problem

I'm not familiar with that mouse. I have had wireless mice that were slow to wake from sleep mode and acted in a similar manner. I just assumed a firmware issue would have been present at first use not a developed problem...?
__________________
Pentium D 935 @ 4.0ghz
AsRock g31
Kingston HyperX T1, 4gb
Radeon HD 5670 @ 860mhz gddr5
Antec High Current Gamer 520
InWin Br665 matx
CyberPower Green CP1500 900W UPS
Acer 20" G205hl
Camera Canon PowerShot SX10is
Quote:
Originally Posted by KSoD View Post
1) Be Respectful Treat other members as you would have them treat you. This means no flaming, insulting, or belittling other members.
Thomas is offline  
Old 07-30-2011, 10:41 PM   #7 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,303
Default Re: Mouse problem

Razer mice have updatable firmware, Thomas, as well as driver updates.
__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is online now  
Old 07-30-2011, 10:47 PM   #8 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,506
Default Re: Mouse problem

Quote:
Originally Posted by Trotter View Post
Razer mice have updatable firmware, Thomas, as well as driver updates.
This.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline  
Old 07-30-2011, 10:59 PM   #9 (permalink)
Super Techie
 
Thomas's Avatar
 
Join Date: Jun 2011
Location: NY USA
Posts: 384
Default Re: Mouse problem

Right, but isn't it unlikely that the issue would not have been present at first use? If the problem developed during use wouldn't it be safe to say it is either the drivers or something degraded in the hardware?
__________________
Pentium D 935 @ 4.0ghz
AsRock g31
Kingston HyperX T1, 4gb
Radeon HD 5670 @ 860mhz gddr5
Antec High Current Gamer 520
InWin Br665 matx
CyberPower Green CP1500 900W UPS
Acer 20" G205hl
Camera Canon PowerShot SX10is
Quote:
Originally Posted by KSoD View Post
1) Be Respectful Treat other members as you would have them treat you. This means no flaming, insulting, or belittling other members.
Thomas is offline  
Old 07-30-2011, 11:11 PM   #10 (permalink)
Newb Techie
 
Join Date: Jul 2011
Posts: 3
Default Re: Mouse problem

Problem Solved! I never upgraded the firmware since I bought this mouse.

Thanks for the help everyone.
__________________

fianftw is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Problem Strealy Hardware Repairs and Troubleshooting 11 04-25-2011 11:22 PM
Mouse problem gator911 Hardware Repairs and Troubleshooting 1 08-16-2006 10:32 PM
Mouse problem susanp Monitors, Printers and Peripherals 5 01-14-2006 01:42 AM
mouse problem kennny2004 Hardware Repairs and Troubleshooting 11 11-20-2005 07:07 AM
Problem w/ mouse Dan DeVille Monitors, Printers and Peripherals 5 07-22-2005 04:15 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.