I am having a Mouse issue - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 09-25-2009, 10:15 PM   #1 (permalink)
Newb Techie
Join Date: Sep 2009
Posts: 3
Default I am having a Mouse issue

My mouse is disconnecting and reconnecting at random intervals. It happens more frequently while playing games but it is not exclusive. I have tried switching the usb and I have tried switching the mouse. I have also noticed that the other devices using usb are working properly. I have been trying to figure this out for a while and I found some stuff about irqs but that didn't seem logical due to the fact that all of my other devices continue to work and it is prevalent across all my usbs.

Hotfix is offline  
Old 09-25-2009, 10:47 PM   #2 (permalink)
Grandfather of Techist

Trotter's Avatar
Join Date: Jan 2005
Location: The South
Posts: 30,955
Default Re: I am having a Mouse issue

Have you tried updating your USB drivers? A simple step, but it may very well cure the ill. Depending on your motherboard, they may or may not be included in the chipset drivers. Check your motherboard manufacturer's website, or the computer's manufacturer if it is a pre-built.


Antec 300 Illusion / Antec EarthWatts EA650 650W / EVGA GTX 760 2GB
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB / WD Red 3TB
G.SKILL Ripjaws 2x2GB DDR3 1600 - Crucial Ballistix Tracer 2x2GB DDR3 1600
Win7 Ult 64-bit - Func MS3 Mouse - CM Storm QuickFire Rapid Mech Keyboard

R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline  
Old 09-26-2009, 03:42 PM   #3 (permalink)
Newb Techie
Join Date: Sep 2009
Posts: 3
Default Re: I am having a Mouse issue

I tried updating my motherboard chipset which includes the usb and it didn't work.
Hotfix is offline  
Old 09-29-2009, 02:41 AM   #4 (permalink)
Newb Techie
Join Date: Sep 2009
Posts: 3
Default Re: I am having a Mouse issue

I seemed to have fixed it. I turned down my report rate and I disabled a seemingly unrelated device that had out of date drivers. I think the report rate is what did it though.
Hotfix is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gigabyte MB and USB mouse problems mistamoni Hardware Repairs and Troubleshooting 1 07-22-2009 02:19 PM
Best Multi Button Gaming Mouse Indobos General Gaming 19 02-22-2009 08:42 PM
Crysis 1.2 patch dario03 PC Gaming 34 08-29-2008 01:42 AM
Seeminly Unsolveable Problem! Reply ASAP! yoshi1476 Microsoft Windows and Software 44 06-12-2008 11:48 PM
mouse issue hdansjr Hardware Repairs and Troubleshooting 3 04-28-2007 10:23 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.