Graphics not showing up - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-02-2009, 12:09 AM   #1 (permalink)
Newb Techie
 
Join Date: Sep 2009
Posts: 9
Default Graphics not showing up

Hi, I've never heard of this problem before, maybe I'm bad at describing it, but I couldn't find anything on Google, so I signed up here to try and see if anyone could help me.

Well, I just recently formatted my C drive a week ago, and I thought I installed everything, it was just until today that I realized something was wrong/missing.

I started this video game and the only things that appeared were the boxes you click on and background pictures, I thought it was the game, so I just exited. Just now, I started another game that was working before I reformatted, and now the same thing is happening.

To be more descriptive, I can't see any 3-d graphics, all text has disappeared, the only thing there are the boxes I click on, such as "Exit" and "Log-in". I can't even see what I type!

So if anyone has had this problem before and has a solution, please tell me. Also, if there's a list of things that I should install after reformatting, so I can play games and stuff, please let me know.

I'm pretty sure that I've installed a good amount of things, but I gotta be sure.

I'm also sure that it's not my computer specs, seeing how I ran the game before.

Thank you in advance for your help.

*I also didn't know whether to put this is "gaming" or "hardware troubleshooting", so hopefully I put it in the write spot.
__________________

bulkykenshln is offline  
Old 09-02-2009, 02:37 AM   #2 (permalink)
True Techie
 
Join Date: Aug 2009
Posts: 122
Default Re: Graphics not showing up

did you update your graphics drivers? if not, what graphics card is installed?
__________________

__________________
http://www.heypcguy.com
leftcoasttech is offline  
Old 09-02-2009, 08:28 PM   #3 (permalink)
Newb Techie
 
Join Date: Sep 2009
Posts: 9
Default Re: Graphics not showing up

Well, I just installed and re-installed my graphics driver. I have an ATI Radeon x1300 series. When I asked my brother he told me it was a rendering problem and he tried to help, I don't know what else to do. Is there like a repair or something that windows can help me with?
bulkykenshln is offline  
Old 09-03-2009, 01:36 AM   #4 (permalink)
True Techie
 
Join Date: Aug 2009
Posts: 122
Default Re: Graphics not showing up

yes, it is a rendering problem, which is why my first thought is drivers. Where did you install the drivers from? If they aren't from ATI's website, go HERE and find the updated drivers.

May also want to run dxdiag (start>run>dxdiag) and run the directx tests in there.
__________________
http://www.heypcguy.com
leftcoasttech is offline  
Old 09-03-2009, 10:57 PM   #5 (permalink)
Newb Techie
 
Join Date: Sep 2009
Posts: 9
Default Re: Graphics not showing up

Ok, I got the drivers from the ATI website and then I decided to run the tests on dxdiag
Only two tests failed and I got these error messages

Direct3D 8 test results: Failure at step 29 (DrawIndexPrimitive): HRESULT = 0x8876017c (Out of video memory)
Direct3D 9 test results: Failure at step 29 (DrawIndexPrimitive): HRESULT = 0x8876017c (Out of video memory)
bulkykenshln is offline  
Old 09-03-2009, 11:33 PM   #6 (permalink)
Newb Techie
 
Join Date: Sep 2009
Posts: 9
Default Re: Graphics not showing up

I read somewhere that a dude fixed his problem with some swtnl or something... i don't know, It didn't work for me, but do you know what that is?
bulkykenshln is offline  
Old 09-04-2009, 12:52 AM   #7 (permalink)
True Techie
 
Join Date: Dec 2008
Location: In my pants.
Posts: 114
Default Re: Graphics not showing up

One solution would be to uninstall your current drivers and install the Omega Drivers, which can be found here.

OmegaDrivers.net - Home of the ATI & NVIDIA Omega Drivers. Home

I'm not completely sure if it will work though, its worth a shot.
TekBubs is offline  
Old 09-04-2009, 01:53 AM   #8 (permalink)
Newb Techie
 
Join Date: Sep 2009
Posts: 9
Default Re: Graphics not showing up

Thank you TekBubs, I uninstalled my drivers and used omega drivers and now I can see it. Also thanks leftcoasttech for all your info and trying to help, there's no "props" or anything to give people, huh.

Problem solved!
bulkykenshln is offline  
Old 09-04-2009, 09:10 AM   #9 (permalink)
Junior Techie
 
Join Date: Feb 2009
Location: United Kingdom
Posts: 99
Default Re: Graphics not showing up

What about DirectX you tried Re-installing DirectX?

Edit: Dont worry
__________________

jambab is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
*Updated* Laptop Graphics Cards Ranking List veg1992 Laptops and Notebooks 98 12-05-2015 10:24 PM
no graphics need help! nastsystems Hardware Repairs and Troubleshooting 6 10-23-2008 02:27 PM
Nvidia Plans Another Re-Branding of Graphics Cards. (..again) veg1992 New Technology and Products 21 10-10-2008 07:31 PM
WHich Graphics Card Should i Get??? Twalker323 New Systems | Building and Buying 52 09-29-2008 09:51 PM
Graphics cards won't work ??? Inigo_Montoya Hardware Repairs and Troubleshooting 6 02-17-2008 10:54 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.