First ever build - Page 3 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-03-2013, 10:31 AM   #21 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,285
Default Re: First ever build

You have the 4/8pin CPU power plugged into the board right?
__________________

__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Old 05-03-2013, 01:23 PM   #22 (permalink)
Newb Techie
 
Join Date: May 2013
Location: New York
Posts: 19
Default Re: First ever build

Yea, I have both power plugs plugged into the board
__________________

Jesusshutt is offline   Reply With Quote
Old 05-03-2013, 01:24 PM   #23 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,285
Default Re: First ever build

Do you have a PSU to borrow from somebody, or another setup to test your PSU? Doing either will figure out if your board or PSU is bad.
__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Old 05-03-2013, 01:34 PM   #24 (permalink)
True Techie
 
Jayteescout's Avatar
 
Join Date: Apr 2013
Location: California
Posts: 145
Default Re: First ever build

Quote:
Originally Posted by PP Mguire View Post
Do you have a PSU to borrow from somebody, or another setup to test your PSU? Doing either will figure out if your board or PSU is bad.
Well he is getting a light on the motherboard to come on. Maybe its the supplimental power?
Jayteescout is offline   Reply With Quote
Old 05-03-2013, 01:37 PM   #25 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,285
Default Re: First ever build

A light just means he's getting some form of voltage, usually 12v. If any of the rails on his PSU is bad it wont turn on regardless. If his board is bad it also wont turn on.
__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Old 05-03-2013, 01:47 PM   #26 (permalink)
True Techie
 
Jayteescout's Avatar
 
Join Date: Apr 2013
Location: California
Posts: 145
Default Re: First ever build

Quote:
Originally Posted by PP Mguire View Post
A light just means he's getting some form of voltage, usually 12v. If any of the rails on his PSU is bad it wont turn on regardless. If his board is bad it also wont turn on.
Oh I see. Now I know what rails are too, we're all learning something today
Jayteescout is offline   Reply With Quote
Old 05-03-2013, 05:25 PM   #27 (permalink)
Newb Techie
 
Join Date: May 2013
Location: New York
Posts: 19
Default Re: First ever build

I have to try and find a PSU to use when I get off work
Jesusshutt is offline   Reply With Quote
Old 05-06-2013, 03:52 PM   #28 (permalink)
Newb Techie
 
Join Date: May 2013
Location: New York
Posts: 19
Default Re: First ever build

Ok guys, I got it on but it won't stay in with the graphics card installed. I have an EVGA Nvidia GTX 660 2GB card. Any suggestions now?
Jesusshutt is offline   Reply With Quote
Old 05-06-2013, 04:06 PM   #29 (permalink)
True Techie
 
Jayteescout's Avatar
 
Join Date: Apr 2013
Location: California
Posts: 145
Default

Just take the graphics card out, the motherboard has on board graphics.
Jayteescout is offline   Reply With Quote
Old 05-06-2013, 04:10 PM   #30 (permalink)
Newb Techie
 
Join Date: May 2013
Location: New York
Posts: 19
Default Re: First ever build

I wanna be able to play games though lol. I'm building a gaming PC, kind of defeats the purpose without a graphics card
__________________

Jesusshutt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.