rma question.. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Closed Thread
Thread Tools Display Modes
Old 01-01-2008, 02:34 PM   #1 (permalink)
Wizard Techie
Drizzt's Avatar
Join Date: Oct 2007
Location: Somewhere inbetween FL and NY
Posts: 3,187
Send a message via AIM to Drizzt
Default rma question..

I cant get in contact with evga since its a holiday and all... but i need to return this board for a new one and i read this

FAQ ID # 57977 - I received my RMA Replacement without any of the accessories, SLI bridge, and chipset fan.

and i dont know if i should belive it ;/ i should just send my regular mobo out and they will send me a good one? Like dont send the sli bridge or the other stuff? and wat about the north bridge fan thing? it came already on the mobo so i should keep it on? gawr

CPU:Q6600 G0 @ 3.7Ghz (410x9 w/1.475v)
Motherboard:Asus P5E X38
Memory:2x2GB OCZ Reapers DDR2 1066
Graphics Card:GTX460 768MB @ 880/1760/2000
Hard Drive:2x WD Black 1TB
Power Supply:Xion 800W
CPU cooling: H50
GPU cooling: Best Stock Cooling I Have Ever Had
Monitor:24" LG
Drizzt is offline  
Old 01-02-2008, 01:13 AM   #2 (permalink)
Junior Techie
Join Date: Dec 2007
Posts: 90
Default Re: rma question..

wait till you get in contact with the company and ask them what they want you to send. some companies want you to send all the accessories, others dont. give them a call, and ask specifically what to and what not to send when rmaing it.

the_patriot2008 is offline  
Old 01-02-2008, 10:17 AM   #3 (permalink)
Lord Techie
veedubfreak's Avatar
Join Date: Jul 2007
Posts: 6,979
Default Re: rma question..

I'm in the process of rma'ing my board to them, but due to their freaking closing my rma wont be approved until tommorow even though i submitted it on the 26th. I'm going to call and raise **** about it. Do you have the advanced rma where they send you a new board then you send back the old one? If so, just send back what they send you. When i talked to a CS person about mine, they mentioned that its basically the bare board. BTW, how long did your 680i last before burning up. I got 6 weeks out of mine, and so far its been sitting on the floor for almost 3 now.
Nothing to see here.
veedubfreak is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rivatuner Question Drewser Overclocking and Modding 2 11-28-2007 02:40 PM
Power Supply Question + Overclocking Question Grievearz New Systems | Building and Buying 21 09-11-2007 11:59 PM
Mobo Question Indobos New Systems | Building and Buying 9 06-28-2007 10:45 PM
question about my processor socket siddanth3 New Systems | Building and Buying 10 04-27-2007 12:14 AM
Case Fan Question Shafra Overclocking and Modding 10 04-18-2007 05:42 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:26 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.