Win10 Networking frustrations

HeTiCu

Solid State Member
Messages
12
Location
United States
Hello.


I have 6 PC's all running Win10 Home. I didn't buy them all at the same time; bought a new one, couldn't get rid of the old one 'cause it still worked, and so on :). The latest addition is a Xidax gaming PC that I bought last month; the others I keep around for redundant backups, running screen savers, etc.



All has been working and networking fine until 2 days ago. When I went to do my daily backup to all other PC's from my main one (the new Xidax) it could not see the other PC's. It could see the 2 NAS's and the Surface3 Tablet (on wi-fi) but it could not see any of the other 5 PC's on ethernet. I checked the Network Discovery settings to see if something got accidentally changed; they were fine. I went to all of the other PC's and they were all seeing everyone else on the network, including the new Xidax. And, I could access the drives on the Xidax from any other PC.


I shut down my router and entire network, switches included, and all PC's. After letting everyone sit powered down for 10 mins, I started all back up. Still could not see any of the other PC's on the Xidax, but everyone else was doing fine.



Next I went to Xidax website and chatted with a tech. He gave me a link to 3 youtube videos explaining how to fix "Windows Network Discovery" issues. All 3 videos outlined the same steps: Start Window's "Services" and change the following to "Automatic" start, instead of "Manual":
-Function Discovery Provider Host
-Function Discovery Resource Publication
-SSDP Discovery
-UPnP Device Host


I did this process to the Xidax and rebooted, as instructed. All 3 videos said this would definitely fix the issue. It did not. I still could not see any of the other PC's from the Xidax.


Next I went to one of the other PC's, and performed the process in "Services" as outlined. After restarting the 4 services, that PC immediately showed up on the Xidax. So, I did the same to another PC; it did NOT show up on the Xidax. I rebooted everyone and still the Xidax is only showing itself and one other PC on the network.


This is very frustrating and raises more questions than I started with:
a) What caused the Xidax to stop seeing everyone else 2 days ago?
b) Is it an issue with my router? I opened up its Admin page and it shows everyone working fine.
c) Why did one PC pop up instantly after performing the process, and another one did not?
d) Why should I be having this issue at all? Did a Win10 update do this, or did one of my apps suddenly decide to do this?



If anyone has had similar issues, and you know what the real problem is, please advise! I am no expert, but I do have over 28 years of accumulative experience and trained instincts with PC's and Windows, and this one is stumping me.


Thanks!
 

AMD_man

Fully Optimized
Messages
1,699
Location
Argentina
Best way to figure out why something broke is to retrace your steps. If you recently made any changes, revert them, even if they don't seem significant at first. (If you have System Protection enabled this would be pretty easy to do.)

Try checking your adapter settings. There are some drivers that can be enabled and disabled that affect network discovery. (You can check this on Control Panel\Network and Internet\Network Connections, right click on the adapter and select properties. Maybe you disabled something unwittingly.)

Also try uninstalling recent Windows updates. It wouldn't be the first time that Microsoft creates updates that break something.

I doubt the router is the culprit since most likely no changes have been made to it. If you did, look into that as well.
 

strollin

Knowitall!
Messages
3,531
Location
N. Calif.
I have encountered an issue using Win 10 where one of my computers could no longer access a share on another computer. I'm not sure how or why this happened (I suspect due to an update) but the solution was to drop and re-create the share.
 

HeTiCu

Solid State Member
Messages
12
Location
United States
Thanks for the replies all. I think I have learned that this is an MS update issue.

A bit after I posted this thread I went back and tried the "Services" routine again. This time it worked (I must have not done it right the first time). But, I had to do this on every PC on my network.

My habit is to shut down all PC's at night, and start back up first thing in the morning. When I did so today, the Xidax could still see all other PC's, but not itself on the network.

I opened the "Services" window and discovered that the Function Discovery Provider Host was NOT running, even though it was still set to start "Automatic", as I set it yesterday. I started it, and the Xidax did not show up. The Function Discovery Resource Publication was already running, so I restarted it. As soon as it came back on, the Xidax popped up on the network.

What has been gnawing at me is: Why have the other PC's not had any network issues? They were all able to see everyone else on the network even before I made the "Services" changes; and still can. The answer is: All of the other PC's are wi-fi capable. The newest addition, the Xidax is not. Its a custom built PC and I specifically declined the addition of a wi-fi card during its build. I prefer ethernet for home PC's.

So, I am now thinking that the last MS update changed how PC's see each other over the network, somehow all intertwined with wi-fi functionality. Its the only thing that makes any sense. If this issue happens again after the next MS update, I suppose I could buy an inexpensive wi-fi card and install it, and see if that resolves the issue permanently.

If anyone else reads this thread and has a more enlightened understanding about this issue, please feel free to comment. Its part of my nature to not put a solved puzzle to rest until I understand the root cause of it. :)
 
Last edited:
Top