wifi/lan bridge fails on some networks

mherber2

Beta member
I've setup a RPI to connect to a wifi network and used iptables to nat all traffic from eth0 to wlan0. When i perform this setup on some networks it works but on other networks it does not - the goal is to take in public wifi (such as from a hotel) and bridge it to ethernet which is connected to a router with other items behind it. Below is a summary of the steps im taking

1. install dnsmasq
2. enable ip forwarding
3. assign eth0 a static
4. configure dnsmasq for eth0
5. connect to wifi using wlan0
6. setup iptables with nat/masquerade

I've also tried to do the windows equivalent with internet connection sharing but was confronted with the same results - The same networks that worked with the pi worked with windows 10 but the networks that would not nat on the pi would not nat on windows either. If i leave my configs in place and connect to a different wifi (that works for this purpose) everything downstream receives internet as expected.

Could there be something upstream from my rpi/win10 bridge that prevents nat'ing on some networks?
 
Top