USB Ports not working after upgraded to W7

ThaHustla

Solid State Member
Messages
7
Hey, Im new to the forums, i got a question. Ok my laptop came equipped with Windows Vista Home Premium (It also has a Windows Vista Sticker on the laptop itself), i upgraded to Windows 7 Home Premium, my usb ports were working at first ( 3-5 weeks), then all of sudden they stopped, i know there not blown because i can plug in my camera and transfer photos, it doesnt auto detect the camera though, i have to plug it in and turn on the power button on the camera for it to detect it, but things such as my Thumb Drives,MP3,ect, doesnt even gets recognized when i plug them in. Now im using Windows XP Home Edition SP2 and still the same thing, and i cant even upgrade to SP3:(, Now im thinking i should go back to Vista, because im thinking that my pc was designed to work smoothly on Vista. What could be the problem? thanks!
 

7D8

In Runtime
Messages
209
It seems like they are working, but you may have auto-start disabled, or something like that.

When you plug in you USB, and then go to Windows Explorer (or My Computer), do you see the drives there?
 

ThaHustla

Solid State Member
Messages
7
yes , only for the camera though, when i plug in my thumb drive or MP3 or phone nothing happens or shows up
 

ThaHustla

Solid State Member
Messages
7
I plugged in my camera, nothing happened, next i turned on the camera and thats when the pc detected it and the drive showed up in "My Computer". Now i just stuck in my usb flash drive and nothing happened, the light didnt come on or anything, the drive is not showing in "My computer" neither, same thing happens with other devices accept my camra
 

JCB1

Daemon Poster
Messages
1,302
does the USB drive work in another computer ? Maybe the USB drive is faulty ?
 

ThaHustla

Solid State Member
Messages
7
does the USB drive work in another computer ? Maybe the USB drive is faulty ?
Yes, they all work good in other PCs, below is the behavior:

Other PCs:

- Camera ( soon as i stick it in the pc detects it without haing to turn the power button on)
- Thumb drive ( the pc automatically detects it and opens the navigation to its folders,files,ect.)
- Mp3 (Automatically gets detected and opens navigation for folders,files,ect.)

My Pc:

- Camera ( Have to turn on the power after plugging it in order for windows to detect it)
- Thumb drive ( Completely does nothing, no light, no detecton sound from pc, drive doesnt show up, nothing
- Mp3 (Same behavior as thumb drive and any other device)
 

strollin

Knowitall!
Messages
3,449
Location
N. Calif.
Do you see any yellow ! icons in Device Manager, especially under the "Universal Serial Bus controllers" section? My guess is that you need to install or reinstall those drivers. What brand/model is your laptop?
 

ThaHustla

Solid State Member
Messages
7
Do you see any yellow ! icons in Device Manager, especially under the "Universal Serial Bus controllers" section? My guess is that you need to install or reinstall those drivers. What brand/model is your laptop?
No yellow markers in device manager, and i have a Toshiba Satellite L305D-S5868 (4GB ram). SN: After doing some brainstorming im now thinking there acting funny is because i have a bad battery (The Battery Icon in the tray has a red x on it while charger is in, and it also doesnt stay alive that long when the charger is out, Windows 7 says "There is a problem with your battery, so your computer might shut down suddenly", although it doesnt shut down when the ac adapter is in. Are USB 2.0 powered through the battery?
Sorry if im confusing anyone...
 
Top