USB 2.0 Problems

Not open for further replies.


Beta member
So lately, I've been finally upgrading my computer slightly. I don't want to spend too much since I'll be building a new one in the next few months, so I figured I'd just get some small upgrades that won't break the bank. I decided to get a new wireless keyboard/mouse combo as the main upgrade, since I'm still using an old 90's wired keyboard and ball mouse. I brought it home and plugged it in. The light on the receiver did not go on. I wondered if my USB port was bad, so I put my external hard drive in that slot and it worked fine. I tried placing the receiver in all of my different USB ports and it never worked. Since my computer is almost 5 years old, I assumed it might not be running because all my USBs were probably 1.1. So I went out and picked up an Adaptec USB 2.0 PCI adapter and threw it in. I plugged in my hard drive and receiver and neither of them worked. The computer read them as USB 2.0 devices but would not work with them. It just searched for their drivers, which neither of them need. After all of this, I wondered if my motherboard couldn't support 2.0. So I checked around and from the looks of it, my motherboard will support 2.0. That being said, I decided to update my BIOS. I got the right file from the manufacturer's website and tried to flash it. It gave me the error: "the program file's part number does not match with your system." I assume that this is because I have the wrong file? But that can't be since I got the right one from the manufacturer's site. Am I going in the right direction for my USB problem, or am I missing something else? If I am going in the right direction, what is the problem I am having when I try to flash my BIOS?

Name AMD Athlon XP
Code Name Barton
Specification AMD Athlon(tm)
Family / Model / Stepping 6 A 0
Extended Family / Model 7 A
Package Socket A
Technology 0.13 um
Supported Instructions Sets MMX, Extended MMX, 3DNow!, Extended 3DNow!, SSE
CPU Clock Speed 1094.2 MHz
Clock multiplier x 11.0
Front Side Bus Frequency 99.5 MHz
Bus Speed 198.9 MHz
L1 Data Cache 64 KBytes, 2-way set associative, 64 Bytes line size
L1 Instruction Cache 64 KBytes, 2-way set associative, 64 Bytes line size
L2 Cache 512 KBytes, 16-way set associative, 64 Bytes line size
L2 Speed 1094.2 MHz (Full)
L2 Location On Chip
L2 Data Prefetch Logic yes
L2 Bus Width 64 bits

Mainboard and chipset
Motherboard manufacturer MICRO-STAR INTERNATIONAL CO., LTD
Motherboard model MS-6570,
BIOS vendor Phoenix Technologies, LTD
BIOS revision 6.00 PG
BIOS release date 04/18/2003
Chipset nVidia nForce2 Ultra 400 rev. C1
Southbridge nVidia nForce2 MCP rev. A3
Sensor chip Winbond W83627HF
Graphic Interface AGP
AGP Status enabled, rev. 3.0
AGP Data Transfer Rate 8x
AGP Max Rate 8x
AGP Side Band Addressing supported, not enabled

DRAM Size 512 MBytes
DRAM Frequency 132.6 MHz
CAS# Latency 2.5 clocks
RAS# to CAS# 3 clocks
RAS# Precharge 3 clocks
Cycle Time (TRAS) 6 clocks
# of memory modules 2
Module 0 Xerox DDR PC2100 - 256 MBytes
Module 1 Xerox DDR PC2100 - 256 MBytes

Windows version Microsoft Windows XP Professional Service Pack 1 (Build 2600)
DirectX version 9.0c

If you need more information, please let me know. Any help would be very much appreciated. Thanks. And sorry for the book. :D
Not open for further replies.
Top Bottom