Unable to Boot from CD (Windows 7 install)

Not open for further replies.


Solid State Member

Ive been trying for quite a few days now to install my copy of windows 7 on my home computer. I have changed the boot order correctly, everything is in the right priority. When i save and exit, windows restarts. I am then prompted to boot from CD like " Press any key to boot from CD........." i cannot do anything as, pressing the keyboard does nothing. I have reformatted my hardrive. After the seconds count down to boot from CD i am displayed with "BOOTMGR is missing" as i assume it then tries to boot from the hardrive, which is starnge as it is not on the BOOT priority list. I have checked that USB support is enabled in BIOS which it is

When i disable the hardrive in BIOS (phoenix) from the SATA 2 channel, it then boots normally from the CD and i am taken into the setup menu for the windows 7 installation. The only problem is i can't install onto the hardrive as it is not detected, displaying a message along the lines of "make sure the controller is enabled in BIOS"

i really don't know what to do, as it seems i have tried everything, maybe try a ps2 keyboard, or last resort take it into a shop

any help would be greatly appreciated, thankyou. :big_smile:
I tried a different keyboard and it was the same. Also enabling the hardrive again gave me the "BOOTMGR is missing error" i disabled the USB boot, making sure my CD drive was the top priority, and only. i can't get back into thw BIOS now lol.

Is the CD your using a burned copy or the original copy?

I had a similar issue with a bad burned copy of a windows server OS, Downloaded from DeVry University
The Abit motherboard screen displays, with 2 options (show post screen) & (press del to enter BIOS) but i am unable to.

after this i am displayed with - Verifying DMI Pool Data......................
Press any key to boot from CD or DVD.....................................
BOOTMGR is missing
Press Ctrl+Alt+Del to restart
yeah i tried it in all USB ports. both keyboards are USB. I just don't understand why is won't detect input. Maybe i should try a PS2 keyboard. thanks
yeah i think it could be. I've tried the 4 ports behind, and the 2 topside. Thanks, ill check for one in the Attic!
Not open for further replies.
Top Bottom