Trying to format hard drive to fat32

Not open for further replies.


Beta member
Hello, I wasn't for sure were to post this, but i thought this was more of a software thing then any of the others. I recently iomega desktop external hard drive. (link to the exact model i got) Iomega 34275 Prestige External Hard Drive - 1TB, USB 2.0 at .I am trying to format it to fat32 so i can use it with my xbox 360.I have tried many different fat32 formatting programs, but none of them are working :cry: .One of the main problems i have is whenever i try running the programs to format it, it says not allocated. I am not sure if this is some kind of firewall preventing me from formating it or what. Thanks for your help in advanced, any help is greatly appreciated!
Okay well you can also use GParted. I have a tutorial all written out on how to do it.

But i would check. Cause as far as i know the largest device that can be used with a XBOX 360 is 16GB. But you can use 2 of them for a total of 32GB of extra storage. I dont know if you will be able to use the full 1TB.

USB Hard Drive Mod for Xbox 360 Storage Enahancment

That will be a good read. You can use a external device, but only to stream content you already have on there. You cant use it for content obtained via the Marketplace. So if that is your intent, sorry to inform you but it wont work.
Thank you for the help, but now i have a bigger problem. Whenever i plug the hard drive into the computer it won't allow me to open it. It shows that its plugged into the computer, but wont allow me to view it. Ive tried uninstalling the driver software, and reinstalling it. I tried everything the products website recommends. Ive tried restarting my computer. Ive tried searching for the device in the computer, but i still can't find it. It says everything is operating correctly when it obviously is not. If someone has any ideas i would greatly appreciate it because i'm frustrated with this to say the least.
Does the drive have a drive letter assigned to it? What is its status in Disk Management?
Start > right click "Computer" > go to "Manage..." > on the left-side panel, click 'Disk management' > find the drive under there and see if it is assigned a drive letter or if there's anything else wrong with it.
Not open for further replies.
Top Bottom