Trouble reading games

Not open for further replies.


What choice did I have?..
TX (Soon CA)
Hey guys I have this slight problem when trying to install a game

I am trying to install The Elder Scrolls III Morrowind but every time I put the CD in the disc drive it just doesn't fully load and it won't auto run.

The setup files and autorun icon aren't fully loaded so I cannot click on them, it's pretty annoying since the game looks brand new...what could be causing this?

Any feedback is greatly appreciated
Have you tried other discs to see if they work in the drive?

Try the Morrowind disc in a different PC to see if it works there.
Yep. Usually when this happens you first check the disc ( for obvious defects, scratches, smudges, etc.)
If it's fine check the drive.

Usually if it's the drive there'll be a few select cds it'll have trouble with. Not sure if it's the encryption on the disc or what though. on my old drive it'd have trouble quite frequently with newer game releases, upgraded the dvd drive and bam no more problems.
Tried to reinstall the drivers but it works fine with other discs, I put it in my laptop and it's giving me the same problem

The setup file won't load the disc just spins, any other suggestions?
I tried the other discs (the expansions) and they work perfectly, the disc has very minor scratches and as far as I can tell my drivers are up to date

Should I just download the ISO? ehh this problems pretty annoying and seems hard to fix :/
Not open for further replies.
Top Bottom