triple monitor setup on 970 4gb not working properly please helllp !!

sam_248

Beta member
Messages
2
Location
england
I had two standard 24-inch Acer monitors working off of my 970 4gb both at 1080 p and they worked fine. Yesterday I bought a 24 inch Asus gaming monitor(Asus VG248QE 24" 144Hz 1ms Gaming Monitor) and now have a triple monitor setup. both my standard Acer monitors are working fine and no problems there but my Asus monitor has a lot of screen tearing and the colours and contrast are so powerful and just won't come down it is not working properly and for the money I paid for it there must be a problem as the colours keep messing up and just the picture looks almost like a cartoon or painting. its very strange.

Is it too much stress on my GPU that's causing it or some other problem I really don't know. any help is highly appreciated as I am really confused about this
so please heeeelllpppp !!!!!
 

sam_248

Beta member
Messages
2
Location
england
it is actually refurbished so i would get a like for like if i trade it in

---------- Post added at 03:55 PM ---------- Previous post was at 03:54 PM ----------

so it is not too much stress on my GPU, all websites said my GPU and motherboard could cope with it.
 

AMD_man

Fully Optimized
Messages
1,699
Location
Argentina
it is actually refurbished so i would get a like for like if i trade it in

---------- Post added at 03:55 PM ---------- Previous post was at 03:54 PM ----------

so it is not too much stress on my GPU, all websites said my GPU and motherboard could cope with it.
If it was your GPU being overloaded you would just loose FPS, not get weird colours and brightness.

Have you tried using only the faluty monitor?
 
Messages
963
Location
US
The new one is 144 Hertz how about the old ones are they also 144 Hertz and if they're not how do you have it set on your card are there all three at the same speed or is one different?
 

Trotter

Grandfather of Techist, , ¯\_(ツ)_/¯
Staff member
Messages
33,049
Location
The South
The new one is 144 Hertz how about the old ones are they also 144 Hertz and if they're not how do you have it set on your card are there all three at the same speed or is one different?
Same that I was thinking.
 

AMD_man

Fully Optimized
Messages
1,699
Location
Argentina
With either Eyefinity or Nvidia Surround all monitors will run at the maximum common refresh rate. I don't think that's the problem.
 

Smart_Guy

Fully Optimized
Messages
4,549
Location
Saudi Arabia
Sam, do what AMD suggested and test the new monitor alone. That's the first step to ever do to analyze such a problem. Make sure cables are connected very well and try playing with the plug while watching a video, for example. See what it shows.

Did you use the triple setup in span mode (resolutions combine according to orientation) or extended desktop mode (you can just move between monitors)? Span mode requires almost identical monitors. There are hidden internal settings other than just the refresh rate and resolution.
 

Cortb

In Runtime
Messages
498
Location
USA
Yeah, try it alone, or at least swap which ports and/or cables the monitors are plugged into.
 
Top