Solaris 10/Network Connection

Status
Not open for further replies.

D-Lyrium

Beta member
Messages
1
I've got a network at home, with a WinXP machine (this one), a WinME machine (my parents' downstairs) both connected to a BT Voyager router. All working fine, yadda yadda.

I recently bought a bare-bones box for a second PC, and have installed Solaris 10 on it (I'm using GNOME/Java Window Thingy). This is my first *nix OS (although I used Solaris 9 with GNOME at uni and liked it a lot) so I'm still green.

How do I connect this to the network? Obviously I've plugged the network cable into it :rolleyes: But software-wise, what do I need to do? When it comes to *nix, I know next to nothing. It's all one big learning experience :D

The only options I can find regarding networks are the Network Monitor (which says I'm connected to a network called lo0, which is idle. I'm guessing this is a default setting?), and Proxy Configuration, which confused me. My limited networking knowledge tells me that a router doesn't count as a proxy anyway, does it? So that's not what I need?

Any help at all would be massively appreciated.
 

IBMan

Daemon Poster
Messages
1,084
people correct me if i'm wrong but doesnt *nix consider call "loopback" lo0? or just lo? Don't ask me how but you may have to install drivers for it.
 

horndude

Fully Optimized
Messages
2,539
make sure your ethernet adapter is recognized and kernel modules loaded, as root type this:
lsmod

that should list all loaded kernel modules and there should be one matching your ethernet adapter, if not, you will have to load one
insmod or modprobe will do this, example:
modprobe 3c509, that would load the kernel module for 3com509 cards

once thats done, turn it on with:
ifconfig eth0 up
then:
dhcpcd eth0

that should work provided solaris sticks with standard *nix standards, there is a way to do this via a GUI Im sure but I dont know how or where it is or what it offers, so you get the generic commandline instructions, see the solaris website for tutorials and instructions

if the above works but you get DNS errors, use the route command ans make sure the routing table is correct, and also add the DNS numbers to the proper file if the dhcp client daemon doesnt do it automatically(it should by default)

the above will probably need added to the boot scripts so you dont have to go thru this every boot up, not sure if solaris uses sysV or BSD style init scripts, see the docs for solaris to find out
 

insecteye

Solid State Member
Messages
9
You don't have drivers installed by default since you only have the 'lo0' (loopback) interface. What you need to do is find what kind of network card your PCs has, and get the Solaris drivers for them. The problem with Solaris is that not all network cards are supported. A network card that works fine under Windows/Linux may not be supported under Solaris. Usually all 3COM cards are supported well , some Intel cards like the IntelPRO also works well .

You'll need to learn how to install the driver.

Usually its with

pkgadd -d driver.name.pkg

Then just follow the instructions.

After you do this, you'll have to either put a static IP or configure DHCP.

Static IP is easy.

Put a static IP in /etc/hosts

Example:
192.168.10 solaris1

Then you have to put "solaris10" in /etc/hostname.XXX where XXX = the interface name you get once the driver is installed when you type ifconfig -a. Could be bge0, hme0, elx0, <-- the name depends on the card manufacturer

Then you need just reboot, or do as horndude suggests for a dhcp IP
 
Status
Not open for further replies.
Top Bottom