Setting up internet connection

Messages
7,841
Location
U.S.
Hey! I need help setting this up.
I just reformatted but I can't get the internet to work.
I'm trying to get the one on the MOBO to work because I need to find what my dedicated network card is so I can get some drivers. Anyone wanna guide me? It's supposed to do it automatically, but it's not.
 

wmorri

Daemon Poster
Messages
1,066
Go to the device manager and find out what the manufacturer and model of the NIC is and then go to their website and download your drivers, then install and you should be all set.

Cheers!
 

CrossCech

Daemon Poster
Messages
825
Go to the device manager and find out what the manufacturer and model of the NIC is

That might be tough to do if the drivers aren't installed yet. Usually there's a big ol' yellow "?" and a generic label "Network Controller" listed in device manager when drivers aren't installed.
 
Messages
7,841
Location
U.S.
Thanks for the help guys, but I already fixed it. I couldn't figure out what was going on. I had the drivers, but it still wouldn't work. So then what I did was, I opened my computer up and I found my dedicate card name (Netgear GA311). The drivers on their website wasn't working for some reason either. So I went and looked for the CD. Installed the drivers and it's up and running. Unfortunately, I had to also install the onboard audio and video drivers. I got the video one installed, but my computer restarted during the audio installation and broke the InstallShield wizard. Then I went to get the Dell Resource CD and I found the drivers of my CD/DVD-ROM gone. I ended up saving the drivers for the LAN, video, and audio on a flash drive. I reformatted again and re-installed. Now it's working perfectly. Thanks for the help again.
 
Top