SCSI/RAID host controller problem!

osokk

In Runtime
Messages
135
On my host controller properties the device status is saying this: Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

I have no clue what to do. I tried uninstalling the driver but cant seem to find one to even uninstall. What exactly is a SCSI/RAID? Please help.
 

Raffaz

Golden Master
Messages
6,798
More info. Computer specs? OS? What were ya doing before this happened? Is it a clean install etc. The more info you give, the easier it will be to help.
 

osokk

In Runtime
Messages
135
Raffaz said:
More info. Computer specs? OS? What were ya doing before this happened? Is it a clean install etc. The more info you give, the easier it will be to help.

sorry, i have a p4 2.4ghz, windows xp home edition. i wasnt really doing anything before this happened that i didnt regularly do. is SCSI/RAID for my video card or for something else?
 

Raffaz

Golden Master
Messages
6,798
SCSI is an interface type like IDE, SATA, etc. RAID is to do with hard drives, its a way of combining more than one drive together in various configurations.

SCSI
http://en.wikipedia.org/wiki/SCSI

RAID
http://en.wikipedia.org/wiki/Redundant_array_of_independent_disks

Also, can you post info about you hard drive and CD/DVD connection types, are they IDE or SATA?
EDIT

Take a look at this fix from MS aswell, code 39 can be an upper/lower filter problem, but it tends to be associated with CD/DVD drives. If you do this then make sure you backup the registry first
http://support.microsoft.com/kb/314060
 

osokk

In Runtime
Messages
135
Raffaz said:
SCSI is an interface type like IDE, SATA, etc. RAID is to do with hard drives, its a way of combining more than one drive together in various configurations.

SCSI
http://en.wikipedia.org/wiki/SCSI

RAID
http://en.wikipedia.org/wiki/Redundant_array_of_independent_disks

Also, can you post info about you hard drive and CD/DVD connection types, are they IDE or SATA?
my cd and dvd drive are IDE my HD is IDE also. I did recently install new RAM and a new PSU. the PSU had SATA connections but i dont have that type so i didnt use it. everything was working fine till i put my new RAM in my pc. the RAM is two sticks of 1024mb DDR. my mobo can take up to 2g of RAM. but i swear before i had 512mb of RAM in both slots the SCSI was not working right and i never had this problem. see what is happening is when i play one of my computer games and error will pop up and the game will crash saying:

This application has encountered a critical error:

ERROR #132 (0x85100084) Fatal Exception
Program: C:\Program Files\World of Warcraft\WoW.exe
Exception: 0xC0000005 (ACCESS_VIOLATION) at 001B:4FE1E75F

The instruction at "0x4FE1E75F" referenced memory at "0x00000008".
The memory could not be "read".
 

osokk

In Runtime
Messages
135
and sometimes it will crash with a different error:


This application has encountered a critical error:

ERROR #124 (0x8510007c) Memory Invalid Block
Program: C:\Program Files\World of Warcraft\WoW.exe
Function: delete[]

SMem3: Pointer does not refer to a valid allocated block of memory
 

Raffaz

Golden Master
Messages
6,798
Check my post above for the edited bit. Also might be worth trying the old memory in again, if the problem clears, then its a problem with the new memory.
 

osokk

In Runtime
Messages
135
Raffaz said:
SCSI is an interface type like IDE, SATA, etc. RAID is to do with hard drives, its a way of combining more than one drive together in various configurations.

SCSI
http://en.wikipedia.org/wiki/SCSI

RAID
http://en.wikipedia.org/wiki/Redundant_array_of_independent_disks

Also, can you post info about you hard drive and CD/DVD connection types, are they IDE or SATA?
EDIT

Take a look at this fix from MS aswell, code 39 can be an upper/lower filter problem, but it tends to be associated with CD/DVD drives. If you do this then make sure you backup the registry first
http://support.microsoft.com/kb/314060

i used method 1 and i had to restart my pc, but didnt fix the problem. also everytime now that i start my pc up i get hardware wizard pops up and install the hardware but it has a problem it keeps saying:

There was a problem installing this hardware
SCSI/RAID Host controller
An error occured during the installation device. The specified service does not exist as an installed service.
 
Top