OS not detecting CDROM, BIOS does

crybllrd

Beta member
Messages
3
Location
USA
I have a new SATA hard drive (empty for the time being) that I am trying to install Windows 7 x64 on.
I also installed a new video card (PCI-e) and an additional 4 gigs of RAM.
When I boot on the new hard drive with the windows cd in the CD-ROM, I get the following:

Reboot and select proper boot device or insert boot media in selected boot device and press a key.

I have used this Windows 7 CD last week so there shouldn't be any problems with it.
When I look in BIOS, I can see both my new SATA hard drive and my IDE CD-ROM, CD-ROM has boot priority.

I can put in an old corrupted hard drive running windows 7 and it will boot into windows, then go to Computer, but I don't see the IDE CD-ROM drive.

So, BIOS detects my CD-ROM but the OS doesn't seem to.
Any ideas?
 

iPwn

..m.0,0.m..,
Messages
3,999
Location
::1
Welcome to the site!

First, reset all of your BIOS settings. There's a jumper on the motherboard to do this but if you don't know where that is, you can simply remove the battery for about 15 minutes. After that, you need to boot into the BIOS and reconfigure it. Go through all of your options as there may be one to enable IDE. Some newer motherboards have the ports disabled. It will detect drives on the port but not initialize them. That should correct the problem.

When you can, pick up a SATA DVD drive too ;)
 

crybllrd

Beta member
Messages
3
Location
USA
Thanks for the reply.
I reset with the jumper on the MB, and it did not seem to help.
If I boot off the old hard drive into windows 7 while both hard disks are hooked up, I can't see the new 2nd (empty) hard drive in the "Computer" file.
And like I said, I can't see the IDE CDROM either.
 

iPwn

..m.0,0.m..,
Messages
3,999
Location
::1
Have you looked through the bios to see if you can enable the IDE ports?

The other HDD may not be showing due to it not having a drive letter assigned.

Try the BIOS settings first, if that doesn't work ill walk you through assigning a drive letter and simply copying your existing installation over.
 

crybllrd

Beta member
Messages
3
Location
USA
*facepalm*
I figured it out: I reseated the IDE cable and all is well.
Thanks for your help, and have a Merry Christmas!
 

Tommy Boy

Golden Master
Messages
8,463
Location
USA
*facepalm*
I figured it out: I reseated the IDE cable and all is well.
Thanks for your help, and have a Merry Christmas!
I've had that problem too, not pushing the connector in all the way. It can drive you nuts until you figure it out....lol

Glad you did, have a Merry Christmas!
 

iPwn

..m.0,0.m..,
Messages
3,999
Location
::1
Sorry, I should have posted originally to check the connections. It's almost always a layer 1 issue! Merry Christmas!
 
Top