no sound through computer speakers when hdmi cable connected to tv

Status
Not open for further replies.

bentz69

Solid State Member
Messages
6
I just installed a gigabyte hd4350 in my hp a1520n desktop bc it has an hdmi output. picture looks good, sound works, however when the hdmi cable is connected to the my samsung lcd tv, i get no sound through my computer speakers even when im not using the tv as a monitor or when the tv is turned off. i get sound through the tv though. when i unplug the hdmi cable from the tv, i get sound on the computer.

is there a fix for this? i have onboard sound enabled in the bios.

i have windows xp 32bit. in the sound and audio device properties, under the audio tab, default device, i see both realtek hd audio output and ati hd audio rear ouput when the hdmi cable is connected. when its not connected, just realtek hd audio is available.

i know i cannot have sound coming through the tv and computer speakers at the same time. is it possible for the sound to be switched back to the computer speakers when the tv is off WITHOUT having to unplug the hdmi cable that goes to the tv?
 

Hefemeister

Lord Techie,
Messages
9,093
Location
Sweden
when the hdmi cable is connected and you want the computer speakers to work set the realtek hd audio as the default output device. You basically have 2 sound cards and you need to tell windows which one you want to use.
 

bentz69

Solid State Member
Messages
6
when the hdmi cable is connected and you want the computer speakers to work set the realtek hd audio as the default output device. You basically have 2 sound cards and you need to tell windows which one you want to use.
i tried that and it doesnt work :( when i set the defualt player to realtek, i still get sound through the tv though...go figure
 

Hefemeister

Lord Techie,
Messages
9,093
Location
Sweden
you could try to disable the ati hd audio in device manager. Then of course you would have to enable it when you want sound through your tv.
 

bentz69

Solid State Member
Messages
6
you could try to disable the ati hd audio in device manager. Then of course you would have to enable it when you want sound through your tv.
that actually worked....however, when i enable it again, the sound on the tv doesnt work. i have to restart lol. so annoying ...EDIT...that idea did work thanks. i dont have to restart. the thing is both devices cannont be enabled at the same time. if i disable the ati driver, the realtek driver has to be enabled for the computer to work and vice versa

THANK YOU SO MUCH

now, is there a way to put shortcut on the desktop for the driver?
 

KSoD

Call me Mak or K, Mod Emeritus
Messages
35,645
Location
C:\
Drivers are not execuatble. So creating a shortcut to the driver on your desktop will not do anything. If you created a shortcut it is most likely that it would try to install the drivers again and cause conflict on your system.

So the best you might be able to do is create a shortcut to the Control Panel on your desktop.
 
Status
Not open for further replies.
Top