New Build Not Posting/Display


In Runtime
Hey Guys,

So I built/am building a media server/mining rig for my dad, but thus far have been unable to get the new system to post/display bios.

CPU: Ryzen 7 1700
Mobo: MSI B350M Gaming Plus
RAM: Corsair Vengeance LPX (CMK4GX4M1A2400C16) 2 x 4GB
PSU: Corsair CX750 (2017 version)
GC: e-Geforce 8600GT (temporary)
HDD: 3 x 3TB WD refurbs
Case: Corsair 200R

After the initial build I hooked it up to the monitor and the computer started, mobo led lights went on and fans whirred but was unable to get a display. The ez-led went on for the cpu initially but then it went off. I re-seated and breadboard'd the system but I was still not getting a display. I tried my dad's other computers power supply on the new system but still didn't get anything. I then did the reverse, and hooked up the new psu to the old computer and it worked. The case didn't come with a speaker so I hooked up the inbuilt speaker in from the old computer to the new motherboard, but upon boot got no beeps. I figured at this point it was probably a bad motherboard, so I RMA'd it. After receiving the new replacement motherboard and installing it, I went to start up the computer again, but the display still was not working. I did notice later that the ez-led cpu indicator was staying on. I figured it had to be a cpu issue, so we RMA'd the 1600x we got, and decided to upgrade to the 1700. Around this time also realized that the first gen ryzens didn't have any APUs, although I had been testing periodically with the graphics card and still getting the same problem. So here I am now with a new build in pieces, not posting with no display, and I don't really know where to go from here. I looked up the RAM and while the specific model I have is not listed as being compatible, it's 8gb variant is. We're going to get a different stick of ram tomorrow, to test it out, but was wondering if anyone had any ideas. Thanks for any help.


Private Joker,
Staff member
Like you pointed out in the end, I'd try different RAM. Though that would have been one of my first steps :p.

Joe C

Fully Optimized
Great Lakes State
You can try a bench test, Which is to pull the board out of the case, leave only the fan/heat sink, cpu and one memory module. Place the board on a non-conductive surface with a power supply connected properly with mouse/kb.
Power it on by temp shorting our the pwr pins (just touch the two pins momentarily with a small blade screwdriver) on the front panel pins and see if it posts and gets you into the bios

I have personally found that it can be more difficult to install DDR4 memory than the older memory with two clips. Only having that one clip to hold the DDR4 memory module seems to make it easier not to get it fully seated into the slot
Last edited:
Top Bottom