Network problems

jfeltt

Solid State Member
Messages
15
Location
usa
I installed Linux Ubuntu as a virtual machine on windows 10. I installed Ubuntu 18.04 using hyper v.
I am unable to establish internet connection. A message states that a network cable is not connected which is incorrect. Any ideas? The windows 10 has a Ethernet connection that is working fine.
 

root

Site Team
Staff member
Messages
8,181
Location
UK
From the top...
In your vswitch setup, are you doing internal networking only or bridged networking (you need bridged to present the machine to the outside world.)
In your VM settings is there a network interface added to the VM
If there is a card added to the VM is it connected (there is a check box the virtually unplug the VM)
Did you add a card type that has a compatible driver in Linux?
 

jfeltt

Solid State Member
Messages
15
Location
usa
From the top...
In your vswitch setup, are you doing internal networking only or bridged networking (you need bridged to present the machine to the outside world.)
In your VM settings is there a network interface added to the VM
If there is a card added to the VM is it connected (there is a check box the virtually unplug the VM)
Did you add a card type that has a compatible driver in Linux?


Thanks for the information. After much effort, I finally was able to connect to the internet. I rebooted several times and not sure what was going on. I'll review your recommendations further and see if I can figure things out.
 
Top