[Need Help]BSOD: Thread Stuck In Device Driver


Beta member
Minidump files: http://www.filedropper.com/minidump
(The file was too big to add as an attachment)

Type: Laptop
Brand: Samsung (Ativ Book 6 NP670Z5E-X01NL)
OS: Windows 10
GPU: AMD Radeon HD8850M
CPU: Intel Core i5-3230M
Motherboard Chipset: Intel Mobile HM76

Dear readers,

Last Tuesday I believe I was on my laptop, and as very often happens my HDD was running at 100%. I've tried to find a solution for this multiple times, and I thought I'd try again. At some point I got a BSOD, which fixed itself afterwards. Don't remember what the error was. I then proceeded to update my drivers, through a program called 'Driver Booster'.

After this program installed a bunch of drivers, I got a BSOD with error code 'Thread stuck in device driver'. This BSOD was on loop, it would show itself during boot every time.

I went into the recovery options (F8 during boot), and tried literally every option I could: -Safe boot, uninstalled/reinstalled drivers, didnt work. System Image Recovery didnt work (I had a few but it wouldn't let me use them due to some error). -System Restore, didn't work. It 'restored' the pc, but the BSOD still occured. -Startup Repair wouldn't run. -'Go back to previous build'-> keep files, didn't work. I then went into Samsung Recovery through pressing F4 during boot. This let me revert the PC back to the point when it was new, so pretty much a full reset. This seemed to work, at first.

So my system reverted back to a clean win8 install like when I first bought it (the 'backup' was from 2013). I proceeded to update to win10 again, thinking the problem was solved because the BSOD was gone. Updating to win10 went fine. However, after it updated to win10, I proceeded to check my drivers through Device Manager, which showed 3 deviced without drivers (and a yellow triangle next to them). I don't exactly remember what those were called, but it was something along the lines of 'USB bus', 'PCI <something>' and 'Video Controller'. I first updated the drivers (automatically through Device Manager) of the first 2 devices I mentioned. The last one, 'Video Controller', was my AMD Radeon HD8800M GPU. I installed the driver for it, and not long after I got the same BSOD again (thread stuck in device driver).

Booting in Safe Boot doesn't show any problems. Not now, and also not when the problems first appeared (before I went back to the backup).

I really don't know what to do. If doing a full reset doesn't fix it, then what will..
I thought about performing a BIOS update but I don't know if this even could work, and if so how to.

If anyone could be of assistance with this, I would be eternally grateful, as I am getting very desperate.

Kind Regards,


Okay, after hours and hours of trial and error, the main problem is fixed.
For some reason, this worked:
-Reverted back to my win8 backup
-Went into safe boot as soon as I could
-Disabled the AMD driver
-Normal boot
-Uninstalled the AMD driver
-Windows automatically reïnstalled the original driver

Since then I haven't had the Thread Stuck In Device Driver BSOD anymore.

However, the problem isn't solved yet.

I am currently getting errors on both my AMD and Intel integrated graphics drivers.
AMD: error 43 (Windows has stopped this device because it has reported problems)
Intel: error 31 (This device is not working properly because Windows cannot load the drivers required for this device)

When I try to update my GPU driver (only way to do so it using AMD installers- I can't download specific drivers ]:< ), it installs the wrong drivers because the ID of my HD Radeon 8850M is appearently the same as the R9 M270x. I tried all different installers (AMD Catalyst for win8, AMD radeon minimal installer for win8.1 and AMD radeon full installer for win8.1). Every installer installed different drivers. Some just listed my driver as 'R9 M200 series', some listed it specifically as the R9 M270x.

Main point is that if I updated to one of those drivers, and then tried to access the grahics settings, I would get a BSOD with error code 0xa0000001. I couldn't revert back to the original driver through device manager, because the driver file was gone (it was listed but when I tried to install it it told me it's just gone, wth windows).

Luckily, Samsung Recovery also had a backup of the original system drivers. Through that, I have now access to 2 HD8800 series drivers (2012 and 2014). However, these still give me the driver error 43.

Long story short: Pc works again, but the GPU doesn't. Furthermore the Intel graphics also have some issue.
Any ideas on how to get my GPU working again? (I don't care much about fixing the intel graphics if I can fix the GPU).




WhoCrashed & SysNative reports:

I couldnt run FurMark: "FurMark requires an OpenGL 2.0 compliant graphics controller. Startup failed.". I guess since my GPU is turned of totally it's not possible to run the test haha. So I decided not to try any other tests because they won't work anyways.
Top Bottom