My Windows Installer isn't working

Status
Not open for further replies.

tech guy

Solid State Member
Messages
17
I have Windows 2000 Professional and somehow, without my knowledge, my Windows Installer is now not working...
I've tried many different programs, but still no luck.
I tried DLing the Windows Installer from Microsoft.com but it just aborted installation because "it was allready installed"

The Error message was something like... The Windows Installer Could Not Be Accessed. Please contact your system admin for more information.
I think it could be because my OS is installed on the E drive(i accidentally installed it to there)
If no one can help, i will just format my HDD
Thanks
 

GerkSide

In Runtime
Messages
121
You can rename drive letters through the registry, i know how to do it , what i dont know how to do is , explain how to do it over the internet. it's too complicated
 

Seloce

In Runtime
Messages
338
...

Right.

Anyway, once your OS partition has been selected, you can't change that drive letter without first formatting the drive and reinstalling the OS to the proper partition. But for future reference, in order to change a drive letter in Win2k you log in as the Administrator account and click on the start button. Then select Administrative Tools > Computer Management. On the left hand side of the new window that has popped up will be a tool for disk management. From there on it is pretty self-explanatory.

As far as the Windows Installer...could you be more specific? I'm not exactly sure what you're talking about. What program are you trying to install when you get this error?
 

tech guy

Solid State Member
Messages
17
Ok... I've reformatted now and it works fine. I think the problem was just a stupid bug or unkown virus. Thanks for your help though. Btw, it was MS ACCESS, uhh... and lots of other programs.
Anyway It's all good now. Thanks.
 

cooltomcat

Beta member
Messages
2
I have the same problem,

I also reformatted my HD, everything was working fine until I installed all the SP's. Now I have the same problem again. So, instead of doing the whole thing over, "Again", how do I fix it. I searched MS knowledge base with no luck, what a surprise. The only fix I found was to boot into safe mode and restart the "msiexec /regserver", but that didn't work. Anyone have any suggestions?
 

tech guy

Solid State Member
Messages
17
Ya, I hate the MS website, it's so huge, and when you find what you want it's not on the server! I wish I could help you man... I don't know. Try installing MS Office 2000, it upgrades the WINDOWS INSTALLER.... That might work, if you've got it
GG
 

subzdude

Beta member
Messages
2
same problem service pack 4

hi i have the same problem installing any *.msi installation packages.
"The Windows installer service can not be accessed. this can occur if you are running safe mode, or if the windows installer is not correctly installed. Contact your support personnel for assistance."
any help would be great
thanks
Phil
 

cooltomcat

Beta member
Messages
2
Windows Installer

I am still not sure what caused the problem, that is the first time I have had it, running Windows 2000 pro, and Office 2000 pro is what caused the problem. I uninstalled the office suite and installed XP Office Pro and that was the end of that.
 

subzdude

Beta member
Messages
2
i found out what the problem is in my service control panel the link to the windows installer was to a file in my "documents and settings/user/local settings/temp/" file in a folder that didn't exist
i copied from the "winnt/system32" the installer program and started the service it worked?

its a temporary solution
does anyone know how to change target files for service configuration.
 
Status
Not open for further replies.
Top