Mouse middle click stopped working

Jahzara

Baseband Member
Messages
48
I have a Logitech M310 wireless mouse.

The middle click will open a link in a new tab.

It stopped working a while ago.

I uninstalled it and replugged the mouse back in and it still doesn't resolve itself.

Any suggestions?
 

kalju

In Runtime
Messages
281
Location
EU
I checked my computers, everyone works and all Logitech mouses works for me.
The problem could be the wrong driver, the wrong mouse setting, or just a worn mouse middle switch - it's a mechanical switch.
 

Jahzara

Baseband Member
Messages
48
I checked my computers, everyone works and all Logitech mouses works for me.
The problem could be the wrong driver, the wrong mouse setting, or just a worn mouse middle switch - it's a mechanical switch.
How do I check the mouse settings? I downloaded the logitech settings software, but not sure what I am looking at.
 

kalju

In Runtime
Messages
281
Location
EU
There is no good medicine or any other method.
You just have to test it yourself. But sometimes it's really quite difficult to find the right driver or utility.
Among other things, this choice also depends on the choices made by your computer manufacturer.
Some manufacturers block all but the ones that are whitelisted.
But if you have a situation where you haven't changed anything and at some point everything doesn't work anymore as it worked before, the problem is somewhere on the machine or in the connections. And it's very difficult to think of what it is.
 

Jahzara

Baseband Member
Messages
48
There is no good medicine or any other method.
You just have to test it yourself. But sometimes it's really quite difficult to find the right driver or utility.
Among other things, this choice also depends on the choices made by your computer manufacturer.
Some manufacturers block all but the ones that are whitelisted.
But if you have a situation where you haven't changed anything and at some point everything doesn't work anymore as it worked before, the problem is somewhere on the machine or in the connections. And it's very difficult to think of what it is.
Okay, thank you. It was the situation as you mentioned, that I hadn't changed anything and everything worked as it should and then stopped working.

It was even more odd because this occurred with my laptop first. I recently got a desktop and the middle click was working again just fine. Now it's stopped working again. So it just makes it even odder. (I almost wonder if it's not something with windows update messing something up.)

I suppose I will have to purchase a new mouse or deal with it as is.
 
Top Bottom