minecraft not working on one psecific pc


Daemon Poster
i installed minecraft on my kid's new laptop (msi gs66 stealth) it crashes while initializing
error: java.lang.error: missing/invalid yggdrasil public key!
exit code: -1

windows, java and graphics card has been updated
i uninstalled and reinstalled minecraft
tried multiple versions and it gives different errors

also tried the bootleg version that i used to have(i have legal versions now so we both can play on network) in case microsoft heavy breathing patrolling here...

bootleg version and his legal version works on my desktop but not on his laptop
bootleg doesnt start on his

i googled it and there seems to be no solution to this from the help fourms" they are supposedly "looking into the problem" which means its on the back list

anyone solve this yggdrassil issue?
ok so it seems to go back to using special characters in your windows account name which my kid did
and now it seems like 2 pieces or software made by same company cant work together... not surpsising it is microsoft after all...
i tried to change account name in multiple different ways but it still reverts to original name with special character
how do i actually make a system wide change to delete the special character in the username.
i really dont want to create another user profile and have to transfer everything to it
one would think that updating your username would be easy in a system thats been around for almost 20 years...
that doesnt update teh user folder
i had to change it in 2 different settings and also registry
in addition it seems i have to edit about 100 registry entries to finally get rid of old name which seems rather dumb...
i did all 3 but without editing the other registry entries hoping that maybe it would auto update and now i have bunch of premission errors for many apps
what a flashback to windows 95 when i had to memorize the entire system folder to know where everything is and what id does to be able to fix things that windows broke all the time
and minecraft still doesnt work

now im getting an error java.nio.file.accessdeniedexception:exit code -1
ended up just reinstalling entire OS

and to confirm. minecraft does not like special characters in windows user name...
it is working now
Disable Discord Overlay
Remove incompatible software
Update your graphics driver
Run Minecraft as an administrator
Disable Mods
Reinstall your Minecraft

Top Bottom