mbr problems

Status
Not open for further replies.

Seloce

In Runtime
Messages
338
I've actually never had problems with the master boot record by itself, so this is a little puzzling to me.

A friend of mine asked me to take a look at his PC. He had recently attempted an install of slackware linux but could not get the LiLo installation to work at all. When trying to just reinstall Win2k, the computer boots from the CD and claims that it cannot read the boot record at all. However, he was still able to create partitions and install normally. The OS, of course, won't boot.

Thoughts? Suggestions?
 

Seloce

In Runtime
Messages
338
sorry, should have listed that in the original post. it's a western digital caviar 20gb. it might be 2 years old.

I have deleted all partitions and recreated the necessary ones. isn't the mbr kept elsewhere though? for some reason, I've always thought of it as a specific portion of the hard drive that you can't get at without special programs that are meant to access it, like LiLo.

other than calling their tech support and getting an rma, is there anything else I could do?
 

Ecniv

<a href="http://www.tech-forums.net/pc/f109/foldin
Messages
1,765
Just type fdisk /mbr at a dos prompt, then install windows, should be fine.
 

Seloce

In Runtime
Messages
338
plot twist !!

I booted from a win98 cd and tried running fdisk. keep in mind that I still have a valid install of win2k on the c: parition. the drive has a second partition for swap use. when running fdisk, the program responds that there are no fixed disks.

thinking it's an ntfs problem, I booted my win2k cd thinking that the recovery console has fdisk. it doesn't. so I page through the commands and I see 'fixboot' and 'fixmbr'. right, these sound like surefire winners. looking at their man pages confirms this. so I run 'fixmbr'...and nothing happens. at all. nothing visibly anyway.

so I try 'fixboot'. success! or so it would seem. it asks if I would like to write a new boot sector. I thought this may help so I allowed it to do so. it completes the action successfully and I reboot.

now, my bios doesn't even recognize the hard drive. ^_^ curiouser and curiouser.
 

Seloce

In Runtime
Messages
338
Oh, and the plot thickens!

Okay, I took the time to actually read the link that MB posted about using fixmbr (which is on the win2k recovery console). So I got that command to work. however, it had no effect. still no hard drive at boot. but the strange part is that the win2k installation detects the unpartitioned space.

time to get WD on the phone?
 

Seloce

In Runtime
Messages
338
nah, they were both ntfs. thanks guys. I'll harass a western digital techie tomorrow morning. hope he's had some coffee. :)
 

Seloce

In Runtime
Messages
338
tech support suggested that I download and run the diagnostic tool from their website (d'oh!) and see what that turns up. but they just rma'd the drive anyway. they feel that it probably just died.
 

mrdinkel

Daemon Poster
Messages
584
One last thing. Try FDISK at the startup. Then check if it will detect them there. If so, you can completely delete them and reinstall W2k. May not be a feasable solution, but it may be the only possibility.
 

sPlAtOiD

Fully Optimized
Messages
1,748
I ran into this same problem the hard drive appered to be ok it would let me format even though the format took extra long.But the drive was shot couldnt install or access drive it was damaged from a power surge.Had to get new drive.
 
Status
Not open for further replies.
Top