LPT1 port disabled in BIOS

Status
Not open for further replies.

bigelow_r

Beta member
Messages
5
I'm helping a friend install a new printer. The only problem is, for some reason, Windows keeps turning the port off. I go into the BIOS setup, and activate the parallel port, but when Windows boots back up, the port is gone. Upon entering the BIOS again, I find the port disabled again.
I even went into the BIOS right after I exited (and I am using save and exit), and found the port still set the way I put it, but when I try to tell Windows the printer is on that port, the port doesn't exist.
It's baffled me thus far, I was hoping someone here might have an idea.
 

bigelow_r

Beta member
Messages
5
Been there, done that

It's not my system, so I'm not sure of the specs. It's 98SE

Like I said in my original post, I already checked to make sure the BIOS is saving settings. But thanks.
 

Shakie

Fully Optimized
Messages
3,313
Location
US
Is the PC loosing time also?

You may need to replace the battery. (Located on motherboard if you didn't know-- looks like a watch battery)

Other than that, I have no idea what else could be causing the error without doing some searching.
 

bigelow_r

Beta member
Messages
5
thanks

Guy- it keeps time fine, but I'll keep that in mind as a possibility
MicroBell - Never had another printer, but I will check the modem settings to see if I can find that port. Device Manager doesn't register any conflicts. It doesn't even register the port.
I'll try this stuff, and I'm still open to any other ideas.
 

Shakie

Fully Optimized
Messages
3,313
Location
US
When you enter into BIOS does it ask you for a password?

If so, do you enter it correctly?
If not, are you just pressing enter to by-pass?

I have seen on some BIOS's that are pw protected, if you enter the wrong pass or just press enter, it will let you in to "have your way" but it won't save any of the changes. However, this is a very rare thing as not very many systems support this.
 

bigelow_r

Beta member
Messages
5
Thanks for the suggestions. Most of your ideas I've already tried, but thanks for the effort. I guess I'll have to look elsewhere.
 

Shakie

Fully Optimized
Messages
3,313
Location
US
I am still searching for an answer-- don't give up on us yet... lol.

Keep checking back.
 

Shakie

Fully Optimized
Messages
3,313
Location
US
Check your IRQ and I/O settings.

By default your IRQ should be 7 and your I/O should be between 0378 and 037F.

If something is using them, change that item to IRQ 2/9, 10, 11, 12-- those are open by default.
 
Status
Not open for further replies.
Top Bottom