Internet Connection is SO REDICULOUSLY SLOW!!

karling07

Daemon Poster
Messages
1,099
Ok guys, I'm really getting tired of my messed up internet connections and am hoping some of you can give me an idea of what is wrong here.

I have a cable connection with Comcast and we just got a WRT54G Wireless Router. One PC is directly connected to the router, and two are connected Wirelessly. Our old router, a Netgear B range router, was okay but it would usually stop working every 10 minutes and then start working again, it was really annoying.

So we get the new linksys router/wireless adapters, thinking woohoo itll be so much faster!

wrong.

I installed everything with their default settings and my speeds are SO SLOW! I dont have the internet stop working every 10 minutes, which is nice, but the speeds are awful. Right now im downloading a file at 5kb/s!

Please anyone let me know if there are some simple steps I can take with the router settings or whatever to speed up a little bit!

I just dont think that with a G range router and a cable connection that I should be having these problems. I dont have wireless security enabled because we are seriously like a mile from any other house or the road.

Thank you
 

VirtualDrone

In Runtime
Messages
451
Try turning the router off and then unplugging all the network cables and plugging them back in. Wait at least a min and turn the router back on. You can also try reseting the router. There should be a little pin hole on the back of the router that you can hold down for 10 seconds to return the router to factory defaults. Sorry I don't know much about this type of stuff but that is the most basic things that you can try first.

Btw next time this should be posted in the networking section. (I think)
 

karling07

Daemon Poster
Messages
1,099
Sorry for putting it in the wrong section - didnt know we had one!

Alright thanks guys, I've noticed something else. I only get the slow speeds during and after downloading torrents. During makes sense because it uses a lot of speed downloading, but why is it slow after (even when bittorrent is shutdown)?

Im back to good speeds by unplugging/replugging everything in like virtualdome suggested, but i shouldnt have to do this every time after torrenting...

Thanks
 

VirtualDrone

In Runtime
Messages
451
You could get the slow speeds after dl because you may of gotten a virus or your bittorrent downloader might still be running in the background. After you shut it down press ctrl,alt,delete and check your processes tab to see if it is still running. If it is end it and see if that helps. It could also be your bittorrent program. Which one do you use? I use azureus and have never had a problem.

Thats weird that you have to unplug the network cables after you have finished dl to get good speed again. Try what I said above and see if that helps.
 
Top