heres a puzzle

Status
Not open for further replies.

Rich97

Baseband Member
Messages
49
im trying to run VMware for linux during the configure process i get this...

Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [no] yes

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]

The directory of kernel headers (version 2.6.11.4-20a-default) does not match
your running kernel (version 2.6.11.4-21.7-default). Even if the module were to
compile successfully, it would not load into the running kernel.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]

im running SuSe Linux 9.3 pro (bash shell) any ideas on how i can get version 2.6.11.4-20a-default and version 2.6.11.4-21.7-defaul to match will be appriciated

thank you:)
 

mikhael

Solid State Member
Messages
12
I tried SuSe 7.3 long time ago and I remember that it should be version of VMware for SuSe. SuSe team placed the libraries to the another location than other distros and nearly every application has to be configured to run on SuSe. In this case it seems that you have kernel 2.6.11.4-21.7 installed and kernel source 2.6.11.4-20a. To be able to install VMWare you need source for the kernel installed, 2.6.11.4-21.7, or kernel for the source.
I do not remember, but if you check in YaST you may be able to find what you need in the software section.
 
Status
Not open for further replies.
Top