Help, Winxp won't install or boot weird advanced help

Status
Not open for further replies.

pures

Beta member
Messages
3
ok heres my problem
I have a 120gig HD IDE that has winxp sp2 installed,
I installed linux to another 10gig ide.
now winxp won't load thru lilo, so I figure ok, we'll fixboot, fixmbr and get winxp back and go from there...however thats a no go...it doesn't work, all I get is BIOS/POST then a blank screen, no errors, nothing but a flashing cursor

So I figure, lets repair, so I do a repair, winxp copies the files over.I'm careful to make sure I get fresh copies of ntldr and ntdetect, and I make sure my boot.ini is good.

Still nothing upon reboot. So I do a fresh install to a different directory...Winxp copies all the files over then goes to reboot...and still NOTHING.

I have literally tried everything...trying different primary disks in the bios...booting lilo from the 120 gig and the 10 gig, and fixmbr'ing all the drives and everyhting...All I get from winxp is a blank screen with a flashing cursor.
I can get linux back up fine recovering from a rescue CD.

Here is a transcript of an IRC conversation I had with some people, so they may hae asked some similar questions and you can see the answers:

<pures> I've tried everything as far as setting bootable flags, and start up disks and loaders...I have Linux installed, and it boots fine with lilo, but I cannot get winxp to load with lilo, so I did a fixmbr, foxboot, no go, still won't load, I've made sure its the primary disk and all that. I've tried to reinstall winxp, its copies the files and goes to reboot, and jsut hangs on a blank screen...I've reinstall ntldr, ntdetect, checked my
[20:17:51] <pures> boot.ini...the farthest I can get is blank screen...I can't even get it to reinstall, formatting is out of the question, cuz it shouldn't be neccessary.
[20:17:56] <pures> no errors or nothing
[20:18:05] <pures> at least if I got an error I'd know whats wrong
[20:19:09] <WrldBFree> repair install
[20:19:19] <pures> done that
[20:19:26] <pures> and I've installed over the install
[20:19:33] <pures> and I've isntalled to a different directory
[20:19:34] <gospit> hey where can i get the old version of java?
[20:19:54] <WrldBFree> youre lilo.conf file is prolly wrong
[20:20:12] <WrldBFree> which flavor of linux is it?
[20:21:12] <pures> WrldBFree: I thought that too, but it won't even load w/ ntldr and windows native loader, when doing a fresh install winxp will write its own mbr...
[20:21:45] <pures> ive reinstall ntdetect and ntldr thinking they might be corrupt, boot.ini looks fine
[20:22:29] <pures> its a 120gig EIDE and was working fine before I installed linux to a different drive..
[20:22:43] <pures> its set as unhidden and active
[20:22:44] <WrldBFree> WHAT FLAVOR OF LINUX IS IT
[20:22:48] <pures> gentoo
[20:23:19] <WrldBFree> format the mbr...
[20:23:35] <pures> yah w/ fixmbr
[20:23:40] <pures> done that a bunch
[20:24:08] <WrldBFree> lkgc then
[20:25:14] <BONE_33> pures, have you ran XP on this machine before?
[20:25:57] <pures> yep
[20:26:02] <pures> lkgc?
[20:26:06] <pures> yeah it was fine
[20:26:25] <pures> now its BIOS/POST everyhitn is detected fine...then blank screen w/ cursor
[20:28:00] <WrldBFree> sounds like a harware failure
[20:28:08] <WrldBFree> edit your boot.ini file to have the
[20:28:13] <WrldBFree> switch /sos
[20:28:52] <pures> got it
[20:29:00] <BONE_33> almost sounds like a driver prob......to me
[20:29:02] <pures> I'm thinking maybe my winxp cd is messed up
[20:29:07] <pures> what type of driver?
[20:29:20] <BONE_33> hard to say...maybe vid card
[20:29:28] <WrldBFree> when you do the /sos switch it will stop on the drive that fails to load
[20:29:35] <pures> I was thinking some partition flag got messed up, but I've rewritten the drives partition...its mbr and boot sector...
[20:29:36] <BONE_33> have you changed any hardware
[20:29:44] <pures> it just gives me nothing to go on
[20:29:45] <pures> no
[20:29:48] <pures> changes in hd
[20:29:57] <WrldBFree> pures are you even listening
[20:30:24] <pures> yes WrldBFree , I have the /sos switch in my boot.ini
[20:30:43] <WrldBFree> and it doesnt show you loading drivers when you boot?
[20:30:45] <DINO> How can i find out what workgroup my computer is in?
[20:30:46] <pures> nope
[20:30:49] <pures> nothing...
[20:30:54] <pures> just bios/post, then blank screen
[20:31:09] <pures> if I boot the other drive I get lilo, where I installed lilo to that drive mbr
[20:31:11] <WrldBFree> start disconecting hardware
[20:31:47] <pures> lilo works fine...linux works fine..I'm thinking about unplugging the other HDD's
[20:34:27] <BONE_33> pures, am I correct here during an XP install when it reboots to finish installation it messes up?
[20:34:52] <pures> yep
[20:35:19] <pures> in all my troubleshooting..thats whats its come down to...and the drive looks fine, all the flags are fine, I mount it in linux, looks good.
[20:35:39] <pures> I mean, I figure, that would re-write the mbr and bootsector to boot the rest of the windows install
[20:35:43] <pures> but nothing
[20:37:00] <BONE_33> what sort of Disk config do you have?
[20:40:55] <pures> 120 gig, 10 gig, 60 gig, cdrw


Please help, I let this go long enough cuz I love linux and just haven't screwed with it, thinking it would be a peice of cake...but theres somehting messed up, and formatting is not an option. I've never had to do it to recover a disk.

Thank you all in advance for even reading this post.

Peace and respect,
Pures
 

Blitze105

Daemon Poster
Messages
1,100
I suggest 2 things.
1. Format, install linux, then install windows.
2. Try creating boot paths to windows xp and linux.

Doubt itll work
-blitze
 

tribalsun

In Runtime
Messages
432
Windows is on the 120, correct? Physically remove your other 2 drives, set your bios boot order correctly and try to boot from the XP disc. If all goes well without the other 2 drives in place then I would again do the fixmbr and try to boot without the cd.
 

pures

Beta member
Messages
3
yeah, I'm not formating...

the linux partition and drive works perfect.. so no need for a format there.

I was thiunking about disconnecting the other drives and doing an install and seeing what happens...cuz there is something fishy going on in the bios or mbr.
yeah its on the 120g.
Linux is on a 10g.
then there is just another storage drive (60 gigs), but that has nothing on it as far as OS's or mbrs.

got this new BFG nvidia 6800 OT OC I'm dying to play with in some directx games...

bah.
 

pures

Beta member
Messages
3
ok,
I just tried installing xp on the 120gig with no other drives plugged in and still a no go.

I'm afraid maybe the partition tables are messed up, which is gonna mean a format ultimately I think?

Anyone have any more advice?

thanks

pures
 

popey

Baseband Member
Messages
71
Sounds like a disk geometry problem or even a hardware problem. Have you tried the diagnostic utility from the disk manufacturers site? Sometimes the only cure is a low level format/zero fill. If thats too drastic there are loads of linux live repair distros with countless disk tools available although most require some familiarity with a command line interface.
 
Status
Not open for further replies.
Top