Help: Display problem!!!

Status
Not open for further replies.

Seboko

Beta member
Messages
4
Hi everyone.
I am having serious problem with my display. My computer is not showing any display at all. It started by taking very long before showing anything on the display after it boots. Now it is showing nothing at all.

I changed monitors but the problem remained. So I am sure the problem is not the monitor.

Does anyone know what I should do in order to actually know what the problem is. What steps would you follow in diagonising the problem?

Your help will be appreciated.:confused:
 

Retro

In Runtime
Messages
220
Try adjusting the brightness and contrast. It sounds like a simple thing to do but I've had monitor reset the brightness and contrast and so nothing was visible on the screen. If you have another monitor try plugging it in and see if it works. This way you can indentify whether it is a problem which lies within your computer or the monitor itself.

On the other hand if you go to,

My Computer -> Control Panel -> System -> Hardware Tab -> Device Manager.

Double click on Display and check the device status.

Let us know if you have any luck,

Retro.
 

Him

Fully Optimized
Messages
3,190
Can you boot into safe mode? Hit F8 while booting, press it every 2 seconds until you get the selection screen and then select safe mode. If you can see things, it is probably your refresh rate. It is too high.
 

bsnyder100

In Runtime
Messages
104
I had a display monitor problem and ended up having to a entirely new MOBO(ASUS P4P800SX), along w/ a lcd 17incher (which wasnt really neccesaary).......... Anyway mabe you could try reseating the monitor sometimes the contacts need to be cleanded off also try hooking the monitor to another computer to confirm the graphics card issue....

Post and let me know.....
 

Seboko

Beta member
Messages
4
Thanx guys for try to help out. I battled with it again last night until very late. Fianally I can see the display, even though the display shows very late (after about 1 minute after booting). But I am not exactly show what made it show finally. The monitor was blank and I kept on pressing the keys on the keyboard and finally the display showed up.

I am still not entirely happy because the displaly takes long to show after booting the machine. I do not switch off anymore because I am afraid it might not show again.

When It was giving me problems this is what I observed. Whenever I switched it on, it seemed to be POSTing the other peripherals: CD ROM drive(LED on cd rom would flash), Hard drive (I could here the disks spinning), keyboard(the Num Lock, Caps Lock and Scroll Lock LEDs would flash). However I watched closely at the floppy disk drive but its LED did not light up neither was there a usual sound from the floppy drive.

I removed the cards, drives and put them back again but there was no luck. I would like to check if it is the graphics card problem but I have to try some other means before I can find a graphics card to try.

More suggestions will be appreciated.
 
Status
Not open for further replies.
Top