Hard drive data recovery failing

Bburnett227

Solid State Member
Messages
6
Location
United States
Hi all, first post.
I have a HP pavilion dv7 laptop that recently died, but comp tech says hard drive should still be good. HPs black screen of death is what happened...I'm past trying to fix it, and bought a new ASUS laptop.
I removed the hard drive from the HP, hooked up the sata cable n power supply a d tgen into the USB port. When I do this, it immediately displays an error message "unknown address" and I cannot get into the hard drive. I'm lost now and can't figure out what to do. Driver is up to date, did a few things that I found online like updating driver, disable/enable through devmgmt, n some others....
The hard drive I removed from the HP was running Windows 7 and my new ASUS is running Windows 10.
HELP!!


Ben
 

MidnightShadow

Night Ninja
Messages
819
Location
USA
Hey, Ben! What exactly do you have this hard drive plugged into? I'm a bit confused on that part. Is it an external enclosure or a dock? Or something else? The new laptop is displaying the message about "unknown address?" Is it a particular software that you're running showing that?
 

Bburnett227

Solid State Member
Messages
6
Location
United States
hard drive is just on the table with an ez connect sata cable adaptor and power supply. power supply plugged directly into hard drive, then a sata cable to usb 3.0 adaptor also plugged into the hard drve, then from the adaptor into a usb port on the new laptop.
the error message is from windows in general, not additional software. as soon as I plug it all together, my computer pops up an error window titled USB Device not recognized. in the window it says "the last usb device you plugged into this computer malfunctioned, and windows does not recognize it." with a windows recommendation of unplugging, and replugging in, which doesn't work.
 

Attachments

Bburnett227

Solid State Member
Messages
6
Location
United States
more info on the dead HP....would turn on, but black screen, blinking caps lock light, orage f12 light (wireless l.e.d) and would not ever boot. three different computer repair places told me different things, vid card overheated and separated from motherboard, motherboard overheated, and then just a very blunt, hp dead screen, get a new comp.. End result was the same on all three diagnoses, buy a new comp, not worth fixing, extract data from hard drive later. but was quoted $120 min, w/a max of $250 to have them extract the data. so I did what everyone does, and said woah ****, looked at you tube and am attempting it myself, for the cost of the ez connect adaptor. ($24)
 

MidnightShadow

Night Ninja
Messages
819
Location
USA
I've never heard of a Kingwin adapter. Some of those things are more reliable than others. I've had my share of issues with those things. Personally, docking stations are way more reliable than those. That said, if it's not seeing the drive, it sounds like it's a faulty adapter. You'll probably have to exchange the adapter for a working one or try using a dock.

If you want somebody to do it to avoid the frustrations that you're having, there are places that can and will do data backups for $100 or less. Geek Squad does them for $100 at unlimited data and there are some mom and pop shops that will do it that way, too. It looks like Staples does it for $70, but I don't know if there is a data limit on it or not.
 

Bburnett227

Solid State Member
Messages
6
Location
United States
Right, but I'm attempting the d.i.y. approach....until total failure. I'll exchange that for an actual docking station tomorrow and try that then....unless someone else has a genius way to help me lol. Thank you
 

carnageX

Private Joker,
Staff member
Messages
25,007
Location
South Dakota
I've used those EZ-Connect adapters at my previous job...they were always trash and were really finicky and seemed like they would only work part of the time.

Get a better external enclosure or dock would be my suggestion. See if you can exchange the EZ Connect one for a better one.
 

Yami

Lady Techie
Messages
8,108
Location
UK
I've used those EZ-Connect adapters at my previous job...they were always trash and were really finicky and seemed like they would only work part of the time.
Same. They were trialed here at my workplace and they were all binned they were so crap.
 
Top