graphics card thingy. problem. big one.

noojoo

Solid State Member
Messages
12
Customer Care Mobility Support Portal (Laptop/Notebook)

I have a T30 IBM laptop with ATI Radeon Mobility 7500.

I accidentally uninstalled the graphics driver. Then I used the Windows driver finder to update the "VGA Display Adapter" (which i presumed was the ATI graphics card)to ATI Radeon 7500 (theres a list with shitloads of graphics cards and their respective drivers). After that I ran a PC game called Freelancer and the screen went black, with a red ( 3/4 inch width ) line that ran from left to right, 3 inches above the bottom of the screen. I turned it off. Then when I turned the computer on again, the IBM bios and startup screen show. Next comes the Windows loading screen, after that, I presume the corrupted ATI Mobility Radeon 7500 driver has been loaded and so the same result happens with the red line.

Please help me, should I install a new OS? is the hardware of my graphics card totally screwed up? should i put in a totally new motherboard?

Distressed boarding school student who desperately needs some gaming enterntainment and whatnot,

Andrew - noojoo@gmail.com for lack thereof :D
 

kchi55

Fully Optimized
Messages
2,276
so everything was working fine up to the point that you started playing that game? can you run your notebook in safemode or is login utterly impossible? don't get a new motherboard, and i'm doubtful that your hard ware was damaged due to the uninstallation of video drivers. try reformatting your computer and going to ati.com to update your drivers.
 

mammikoura

Golden Master
Messages
7,459
Go to control panel and uninstall the vid card drivers. If u can't boot into normal windows mode then use vga mode.

After the drivers have been uninstalled windows should work fine, then go and get the proper drivers for ur vid card from ati's website and install them.
 

noojoo

Solid State Member
Messages
12
ok thanks kchi55 and mammikoura.

unfortunately kchi55, i cant go on the internet with that computer cuz the screens black.

i can get to the windows xp loading screen, u know with the bar and the little green blocks moving like a caterpillar. but after that, when theres supposed to be a login screen , the screens goes black with the red line i was describing.

how do u get into vga mode mammikoura?

thanx again for the help :D appreciate it
 

mammikoura

Golden Master
Messages
7,459
usually u press F8 during the bootup, after bios but before xp loading screen. U can also just keep pressing the key all the time.

Then it should give u a screen where it asks u in which mode u want to start windows in. Choose vga mode and windows should load just fine so u can delete the old drivers. Once there is no drivers normal windows mode should work.
 

noojoo

Solid State Member
Messages
12
ok now wt if f8 didnt work. and after i did reach the bootup choosing screen, (after turning my comp off during window loading) it didnt work. i think there was software installed onto my comp which disabled some of the options. (i reworked back cmd and ctrlaltdel by registry editing)

alternative--->
i log on. ( i cant see anything, so ill have to do this blind)

press ctrl+esc, which pops the windows menu(cuz the ibm t30 dosnt hav a windows shortcut key)

press the Up key 3 times. (past shut down, then logoff, into run)

then type in "cmd"

press enter

then type "bootcfg/addsw/bv"

wud that work??
 
Top