Flash Player stopped working, because of an NPAPI

postcd

Banned
Messages
63
Location
CZ
Hello,

on a website is code:

<embed width="800" height="600" target="http://IPHERE:8002" volume="100" loop="no" autoplay="no" name="VLC" type="application/x-vlc-plugin"></embed>

and chrome stopped showing video stream because it no longer supports NPAPI, but only PPAPI, linking me to a page: https://support.google.com/chrome/answer/6213033

I want to ask for help on how to modiffy above mentioned code so i can stream the video on a webpage?

Thank you
 

root

Site Team
Staff member
Messages
8,181
Location
UK
it's simple,
the browser doesn't support it anymore. if you want to view something in flash then use a different browser. (e.g. ie 11)

java applets are going the same way, (JRE is NPAPI) so the latest browsers last chrome, and the new MS edge browser don't support that).

if you have a video encode if h.264 and use HTML 5 to embed it.
 

postcd

Banned
Messages
63
Location
CZ
thank You for your reply.

> if you have a video encode if h.264 and use HTML 5 to embed it.

I have an online stream which i cant modify anyhow, so it is not an video file which i can anyhow encode i think.

Please any idea how to modify above mentioned code so its compatible with Chrome?

I also tried the code provided there:
https://chromium.googlesource.com/c...es/media_stream_video/media_stream_video.html

and inside embed tag added parameter:
target="http://IPHERE:8002"

but Firefox tells me that: "A plugin is needed to display this content"
its probably because i dont have Java, but i cant install it because of error im unable to fix.
 
Top Bottom